2

I am working with 'dd' command, and I have a Ubuntu Mate ISO, my stick is sdb, these are steps:

umount /dev/sdb1

sudo dd if=/path/ubuntu-mate-16.04-desktop-amd64.iso of=/dev/sdb

but this does not seem to work.

what am I doing wrong?


before 'dd' command:

before dd command

after 'dd' command:

after dd command

after dd command

And when reset does not enter the usb.

  • 1
    what do you mean by "does not seem to work"? What are you expecting to happen, and how does that differ from what is actually happening? What error messages are you seeing, if any? don't reply in a comment with this info, edit your question and add it. – cas May 16 '16 at 3:33
1

As I don't have a dedicated USB pendrive for my ISOs, so I usually end doing it very often and had to come up with a quick and reliable way to do it.

Most of the time I do this for my Arch Linux or Arch Bang installs. So I'm using those distributions for the ISO names.

This is what I do:

dd if=/path/to/image.iso of=/dev/sd[usb-device] bs=[bytes-size] && sync

Where: [usb-device] is the letter corresponding to the usb device reported by dmesg. Note there is no partition number. It's the whole USB drive.

[bytes-size] depending on the distribution, usually 1024kb or 4M. Maybe you are missing this and that's why it's failing.

Example: (Warning: this will erase everything on the /dev/sde drive)

dd if=archbang-010316-x86_64.iso of=/dev/sde bs=4M && sync

I have seen there are problems with UEFI/EFI BIOS sometimes with this, so you should check the BIOS is in compatible mode (disable secure boot or windows boot) and if that fails, the answer above seems to be what I would do.

mkdir -p /mnt/{iso,usb}
mount -o loop archlinux-2016.04.01-dual.iso /mnt/iso
mount /dev/sdXn /mnt/usb
cp -a /mnt/iso/* /mnt/usb
sync
umount /mnt/iso

Where sdXn is the drive and partition. Remember UEFI need a VFAT32 partition for the initramfs. Maybe creating it with GPT

1

It appears part of the old gpt table is persisting, likely because the iso write is much smaller than the flash drive. So you should completely wipe it first.

First make sure its entirely unmounted:

umount /dev/sdb*

Then delete existing fs on drive ( arch wiki suggestion)

wipefs --all /dev/sdb

Overwrite entire drive

dd if=/dev/zero of=/dev/sdb

Now try to write again with the same command you've been using.

If that doesn't work, make sure it is a bootable livecd type iso.

Personally I use Rufus, but I understand sometimes you can't use a GUI

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.