1

I've recently installed Debian on my old Itautec pc, from a live USB with a Jessie net install. Everything was working fine, but after trying to restore configurations from an old server, I accidentally erased the /etc/ folder and can't correctly boot the system anymore, being sent to an initramfs/BusyBox shell. I've tried to boot from the same USB drive with the latest stable net install, which I made using uNetBootin in Windows, but the option simply does not appear on my boot setup menu (CMOS Setup Utility) anymore. Before, it appeared as "USB HDD: SanDisk Cruzer Glide" in the Hard Disk Boot Priority list, but now it doesn't. I've tried to boot from the USB in other machines and it worked fine, though.

Another forum recommended to try to boot the USB from grub, using:

set root=(usb device, partition)
chainloader +1
boot

But after following these steps, I'd get a black screen with the blinking "-".

So, I was wondering could this inability to boot from the usb have something to do with Grub 2 configurations from the Debian install? Is there anyway to format the hard disk from the initramfs/busybox shell and try again with everything clean? I'm open to any suggestions, and can try to give more details as asked.

Thanks for your attention!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.