2

I have Ubuntu 16.04 installed ( updated through 15.04 -> 15.10 ) . and Windows 10 Dual booted along with it .

I tried to Apricity OS rc1 ( md5sum -> 58ad9c6172a2f45e31bd756d83107058 ) to my laptop and it gave several errors , after that I found I have to add fat32 formatted boot/efi partition instead adding /boot to the installation. 1GB-> boot/efi 50GB-> /home 50GB-> / 8GB -> swap

so the installation process worked perfectly without any errors .

but the problem is grub only showing ubuntu no any other OS , I can forget about windows , since it can be recover . but still need to get ApricityOS to the grub which is installed in sda10 . since I'm considering moving to Arch from ubuntu , think Apricity OS will be good move to initiate with.

1 Answer 1

1

First, ensure that os-prober is installed in Ubuntu. If not:

sudo apt-get install os-prober

Double check that your Grub config is stored in the usual place:

ls /boot/grub/
grub.cfg

Then generate a new one:

grub-mkconfig -o /boot/grub/grub.cfg

Hopefully this should solve the problem. If not, let us know.

2
  • Thank you for the solution. this should work also . I again run the boot repair in the ubuntu and fixed it using recommended fix option . Commented May 19, 2016 at 19:00
  • Glad to hear it mate, all the best. Commented May 24, 2016 at 12:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .