1

EDITED: SOLUTION FOUND: After contacting godaddy, a solution was found very fast (great service!). What seemed to be the problem was that my IP Address was being blocked, given that I had too many failed login attempts. After requesting the IP to be unblocked and waiting a little bit the problem was solved. If the godaddy representative that attended the call is reading this THANK YOU DUDE!


I have a godaddy account (shared hosting), and it comes with the ability to use the linux terminal via SSH Access. When I first obtained PuTTy, everything was working fine, however I tried to login 10 (more or less) different times with the wrong Username and Password, and now every time I click Open in PuTTy, I get the black terminal page but with this popup error message:

Network error: Software caused connection abort

Here is the actual image: http://i.imgur.com/E9cQB3M.png

I don't even have the option to type anything in the black terminal anymore and no writing appears inside the terminal, as if it were frozen.

I contacted Godaddy (great service btw) and we did the following tests:

  • Downloaded putty on my other laptop, got same error when attempting connection
  • Godaddy managed to log in themselves via SSH and managed without a problem
  • I constantly used the "enable" option in godaddys CPanel under SSH Access, so that was not the problem

The final test we did was I entered my cmd.exe and ran the following command:

tracert 108.blah.blah.blah

108.blah.blah.blah represents the IP Address of my websites, and there is where we found a problem. I was obtaining a lot of values like 147 ms, and I also had 5 lines that appeared like: * * *

here is an img of the tracert results http://i.imgur.com/MzYKoSI.png

Godaddy mentioned that this seemed to be the issue and to contact my ISP, though what I can't figure out is why when I first ran PuTTy, I had absolutely no problem with it until I failed to access the account 10 times (more or less). I told that to Godaddy, and that maybe there might be some config file not giving me access because it believes I might have tried to hack inside, though it appears they didn't find anything.

QUESTION: does anyone know what might be the problem here? I personally don't see it being an ISP problem if I had access in the beginning, so might someone know if there is a firewall issue somewhere on godaddy's linux server? Also I tried entering at different times of the day for two days and had the same problem, so I don't believe personally it is a connection issue.

  • Not without the output you got from the tracert. My first guess is that they blocked your IP for security reasons and the agent didn't think of that possibility. Comparing the output of tracert from a machine that has access with yours may give that clarification. – Julie Pelletier May 14 '16 at 18:26
  • @JuliePelletier you mean like me doing a tracert 108.blah.blah.blah with an ip of another server of theirs with similar configurations? – Webeng May 14 '16 at 18:28
  • No, I mean to include your exact tracert output that Godaddy asked you to do in your question. Being paranoid won't really protect you and will prevent anyone from clarifying the actual problem. – Julie Pelletier May 14 '16 at 18:29
  • Note that I'm certainly not asking your private information, namely the username and password which you should not share. – Julie Pelletier May 14 '16 at 18:34
  • @JuliePelletier I understand hahah. Might I ask what kinds of tests you would like to do with the IP address of my website? the difference between the command in my question and the command godaddy gave is just the IP itself. I hope you understand why I am being cautious hahaha. – Webeng May 14 '16 at 18:36
2

In most of these cases, the problem comes from the IP being blocked on the server for security reasons such as too many failed login attempts and the such.

That kind of situation can only be resolved by the host's security team or waiting long enough for the automatic block to be removed, typically 24 hours.

0

Also be sure you are not sitting behind a NAT router. I banged my head for a day then finally checked with our networking folks and found this to be the case. Once an exception was placed in NAT all worked as it should have.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.