1

After upgrading Debian Squeeze to Jessie (via Wheezy) last month I noticed I had no sound anywhere. I've looked through several Debian wiki pages and forum posts and tried (parts of) several suggested solutions but I got stuck early on because some vital directories and/or (virtual) files seem to be missing in my OS. For starters :

# alsactl init
alsactl: init:1758: No soundcards found...

But on the other hand :

lspci -nn | grep Audio
00:1b.0 Audio device [0403]: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio [8086:3b56] (rev 05)
01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Redwood HDMI Audio [Radeon HD 5000 Series] [1002:aa60]

I have no /etc/modprobe.d/alsa-base.conf. Contents of modprobe.d are :

ls /etc/modprobe.d/
dkms.conf         modesetting.conf       oss4-base_noOSS3.conf
fbdev-blacklist.conf  oss4-base.conf         oss-compat.conf
local-b43.conf        oss4-base_noALSA.conf  osspd.conf

There's also no /proc/asound. I've already tried apt-get update and apt-get upgrade more times than I care to remember. Also tried reconfiguring and reinstalling alsa-base. (BTW alsa packages are installed.)

Finally, yesterday I recompiled a kernel with alsa activated and oss deactivated but the result is still the same : no sound, no soundcards found by alsactl init. Apparently during installation last month soundcards and drivers were correctly identified:

cat /var/log/installer/hardware-summary | grep snd
lspci -knn:    Kernel driver in use: snd_hda_intel
lspci -knn:    Kernel driver in use: snd_hda_intel
lsmod: snd_hda_codec_conexant    17841  1
lsmod: snd_hda_codec_generic    63181  1 snd_hda_codec_conexant
lsmod: snd_hda_codec_hdmi     45118  1
lsmod: snd_hda_intel          26407  0
lsmod: snd_hda_controller     26646  1 snd_hda_intel
lsmod: snd_hda_codec         104500  5      snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_intel,snd_hda_controller
lsmod: snd_hwdep              13148  1 snd_hda_codec
lsmod: snd_pcm                88662  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_controller
lsmod: snd_timer              26614  1 snd_pcm
lsmod: snd                    65244  8 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
lsmod: soundcore              13026  2 snd,snd_hda_codec
/proc/interrupts:  42:         37         39         37         37   PCI-MSI-edge      snd_hda_intel
/proc/interrupts:  43:          7          6          7          7   PCI-MSI-edge      snd_hda_intel

But there's also this :

cat /dev/sndstat
OSS 4.2 (b 2010/201503091929)GPL (C) 4Front Technologies 1996-2011

Source configration options: --enable-libsalsa=NO --config-vmix=FIXEDPOINT

Audio devices:
0: HD Audio play pcm1 (OUTPUT)
1: HD Audio play pcm2 (OUTPUT)
2: HD Audio rec rec1 (INPUT)
3: HD Audio rec rec2 (INPUT)
4: HD Audio rec rec3 (INPUT)

MIDI devices:

Mixers:
0: High Definition Audio 0x14f15069

History:
/dev/oss/oss_hdaudio0/pcm0.05: pid 782 cmd 'nasd' OUT
/dev/oss/oss_hdaudio0/pcm1.01: pid 782 cmd 'nasd' IN


NOTICE! Device numbers shown above may be wrong.
    Use the `ossinfo` command to find out the correct device names.

Output of dpkg -l \*oss\* :

dpkg -l \*oss\*
Gevraagd=(U)onbekend/(I)nstalleren/ve(R)wijderen/(P)wissen/(H)ouden
| Status=Niet/Inst/Conf/Uitgep/halF-geconf/Halfgeïnst/verWacht-trig/Trig-bezig
|/ Fout?=(geen)/heRinst. nodig/ (Status,Fout: hoofdletter=ernstig)
||/ Naam           Versie       Architectuur Omschrijving
+++-==============-============-============-=================================
ii  alsa-oss       1.0.28-1     amd64        ALSA wrapper for OSS applications
un  audiooss       <geen>       <geen>       (geen beschrijving beschikbaar)
un  dpkg-cross     <geen>       <geen>       (geen beschrijving beschikbaar)
un  libsdl1.2-oss  <geen>       <geen>       (geen beschrijving beschikbaar)
un  libsdl1.2debia <geen>       <geen>       (geen beschrijving beschikbaar)
ii  libsox-fmt-oss 14.4.1-5     amd64        SoX OSS format I/O library
un  mpg123-oss-3dn <geen>       <geen>       (geen beschrijving beschikbaar)
un  mpg123-oss-i48 <geen>       <geen>       (geen beschrijving beschikbaar)
ii  oss-compat     6            amd64        Open Sound System (OSS) compatibi
ii  oss4-base      4.2-build201 amd64        Open Sound System - base package
ii  oss4-dkms      4.2-build201 amd64        Open Sound System - DKMS module s
un  oss4-modules   <geen>       <geen>       (geen beschrijving beschikbaar)
rc  osspd          1.3.2-6      amd64        OSS Proxy Daemon: Userland OSS em
un  osspd-backend  <geen>       <geen>       (geen beschrijving beschikbaar)
un  osspd-pulseaud <geen>       <geen>       (geen beschrijving beschikbaar)
ii  solfege-oss    3.22.2-2     amd64        OSS module for GNU Solfege

(geen beschrijving beschikbaar) = (no description available)

Does anyone have any suggestions before I go for a complete reinstall?

0

1 Answer 1

3

You have OSS4 installed, using dkms which means it automatically rebuilds modules for your kernel as necessary. The following should allow the sound card to be managed by ALSA instead:

  • remove oss4-dkms and oss4-base:

    dpkg --purge oss4-dkms oss4-base
    
  • check that the modules have been removed:

    dkms status
    
  • if necessary, use dkms remove to remove the remaining OSS4 modules (check /var/lib/dkms);

  • reboot.

After rebooting, /proc/asound/cards should list your sound cards. The default kernel, linux-image-3.16.0-4-amd64 (assuming you're using amd64) should work fine in this configuration too; the OSS modules it includes provide OSS compatibility on top of ALSA (with the help of oss-compat).

7
  • Why is having OSS installed blocking the sound from working? May 14, 2016 at 13:50
  • @Stephen Kitt : Did as you suggested and I have sound again, not yet in all applications but that's probably due to individual configuration stuff. At the end of removing oss4-* I got the message that /var/lib/oss4 and /etc/oss4 weren't empty and therefor weren't removed. Can/should I remove them manually now that sound is working with alsa? Anyway, thanks a million.
    – guy13
    May 14, 2016 at 14:01
  • 2
    @FaheemMitha, most software in Jessie expects ALSA, and liboss4-salsa-asound2 wasn't installed. It might be possible to get a working system using OSS4, but I thought it better to switch to ALSA since that's what's tested these days. May 14, 2016 at 14:05
  • 1
    @guy13, it should be safe to remove those directories manually. You can always back them up somewhere... May 14, 2016 at 14:06
  • 2
    @FaheemMitha it's either OSS drivers, or ALSA drivers, not both (for the hardware). Above that you can use OSS or ALSA APIs, with a compatibility layer if necessary. Using OSS hardware drivers is rather unusual nowadays, yes! May 14, 2016 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .