1

I see the following repositories when I do a repolist:

1) google-chrome
2) rpmfusion-nonfree 
3) rpmfusion-nonfree-updates-testing

But commands like yum install vlc and others line yum install gstream-plugins-ugly do not not work.

I tried installing the free rpmfusion repos

[root@dhcp223-30 yum.repos.d]# sudo rpm -ivh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
Retrieving http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-stable.noarch.rpm
warning: /var/tmp/rpm-tmp.M25qoM: Header V4 RSA/SHA1 Signature, key ID 97f4d1c1: NOKEY
Preparing...                          ################################# [100%]
package rpmfusion-free-release-23-0.1.noarch (which is newer than rpmfusion-free-release-22-1.noarch) is already installed
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora from install of rpmfusion-free-release-22-1.noarch conflicts with file from package rpmfusion-free-release-23-0.1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-latest from install of rpmfusion-free-release-22-1.noarch conflicts with file from package rpmfusion-free-release-23-0.1.noarch
file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-rawhide from install of rpmfusion-free-release-22-1.noarch conflicts with file from package rpmfusion-free-release-23-0.1.noarch
file /etc/yum.repos.d/rpmfusion-free-updates-testing.repo from install of rpmfusion-free-release-22-1.noarch conflicts with file from package rpmfusion-free-release-23-0.1.noarch
file /etc/yum.repos.d/rpmfusion-free-updates.repo from install of rpmfusion-free-release-22-1.noarch conflicts with file from package rpmfusion-free-release-23-0.1.noarch

and then enabling it

[root@dhcp223-30 yum.repos.d]# sudo dnf config-manager --enablerepo=rpmfusion-free-release-stable
Error: Unknown repo: 'rpmfusion-free-release-stable'

Please use the link to find the output of dnf repolist all

http://pastebin.com/AqgCdCSU

TIA

1

Reworked answer based on new info; and a couple of quick edits subsequently -

What Happened to your Fedora Repos?

Did you edit out the fedora repos from your dnf repolist outputs? Because you don't appear to have them...

And maybe lets confirm you are running fedora 23 :) cat /etc/redhat-release

Assuming you are truly missing them, do the following, otherwise jump ahead to the 'At least we have fedora repos' section

dnf install ftp://195.220.108.108/linux/fedora/linux/releases/23/Everything/x86_64/os/Packages/f/fedora-repos-23-1.noarch.rpm
# make sure they are enabled

dnf config-manager --set-enabled fedora updates updates-testing
# clean
dnf clean all

# Optional, potentially large update, but I highly recommend it.
dnf update

If you got a large update, particularly if the kernel, systemd, dnf / yum / rpm were updated then reboot before contuining:

At Least We Have Fedora Repos Now

The following commands will remove all of the rpmfusion repos and reinstall the latest version. Barring any errors on route, we should then be able to enable them appropriately.

If you get failures similar to those you received before:

file /etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora from install of rpmfusion-free-release-22-1.noarch conflicts with file from package rpmfusion-free-release-23-0.1.noarch

at any point, stop, and move right to the section on removing GPG keys from RPM, located at the bottom of this post.

Hopefully you don't have to do that it. It's not pleasant.


One caveat - I don't have any more fedora 23 machines; just F24, so I tested this code on one of those. Shouldn't be an issue, and I note a couple spots where it lead to a bit of uncertainty.

Run all commands as root. If at any point an uninstall command results in numerous 'dependent' packages also being designed for uninstallation, do not continue - that shouldn't happen.

# clean up dnf just because
dnf clean all

# pull together a list of all installed rpmfusion packages
rpmflst=$(rpm -qa | grep rpmfusion)

# for a sanity check, review that output; we're going to uninstall them all
echo $rpmflst

#now remove - only click 'y' if it looks reasonable
dnf remove $rpmflst

# Double check for any stragglers
cd /etc/yum.repos.d/
ll

# Delete any .repo files (or mv them somewhere like ~/ to be safe) EXCEPT these EDIT - was 3, now 4 - forgot google:
#fedora.repo
#fedora-updates.repo
#fedora-updates-testing.repo
#google-chrome.repo

# install 'free'
dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-23.noarch.rpm

# install 'not-free'
dnf install http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-23.noarch.rpm

# The first repo should be the only one needed for vlc, but we will enable a couple others (for depdendencies) as rpmfusion is harmless (I couldn't test this as vlc is in the rawhide repo for F24 beta)

dnf config-manager --set-enabled rpmfusion-free-updates-testing rpmfusion-free rpmfusion-free-updates-testing rpmfusion-nonfree rpmfusion-nonfree-updates rpmfusion-nonfree-updates-testing

# Some of those enables could fail - if they are empty, etc. For that type of error keep on going
# tidy up
dnf clean all

# Download metadata (optional - its a check of the config without involving an install)
dnf makecache

# assuming you've had no GPG errors, try installing vlc now
dnf install vlc

GPG Conflict Error Resolution

Basically we need to just delete the GPG keys that report conflicts. There is a clear guide at the link below, and since this isn't the topic of your question, and I'm sick of typing, I'll just point you to it https://blog.laimbock.com/2014/05/02/how-to-remove-an-imported-gpg-key-from-rpm/

Once the offending GPG key is removed, you should be able to retry the step that failed and continue from there.



If you subsequently get an error such as "missing GPG key for repo XYZ", then edit the repository file (I can't find CLI option that persists), as follows:

cd /etc/yum.repos.d/
# Find the file that contains the offending repo config (e.g. rpmfusion-free-updates-testing)
vi rpmfusion-free-updates-testing.repo
Find the line where gpgcheck=1 and change to gpgcheck=0

Now you should be able to continue on.

  • @The_Lost_Avatar I hope this works as intended - please let me know if it does not so that I can update it for my own benefit. – Argonauts May 14 '16 at 11:54
  • Thanks for the answer @Argonauts. The root cause of the problem are the fedora repos only. I don't have any of them in the /etc/yum.repos.d/ directory.The distro is fedora only and i didn't fiddle with the repo files. pastebin.com/ZJasq8Bz – The_Lost_Avatar May 14 '16 at 19:33
  • Somehow the fedora repos went missing from my system. As such I downloaded them separately and followed the steps you listed and it worked. – The_Lost_Avatar May 15 '16 at 11:07
  • Great - glad to hear it – Argonauts May 15 '16 at 16:57
0

You need to enable the rpmfusion free repository also. From a command line issue su -c 'dnf install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm.

Command line found here.

  • This is what I get back when I try to do this Package rpmfusion-free-release-23-0.1.noarch is already installed, skipping. Dependencies resolved. Nothing to do. Complete! – The_Lost_Avatar May 14 '16 at 9:18
  • Interesting, are perhaps some of your repos disabled? I don't see for instance the basic fedora repo on your repolist. Try issuing yum-config-manager -enable fedora and yum-config-manager -enable rpmfusion-free. – ojs May 14 '16 at 9:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.