1

I'm currently trying to install Linux Mint alongside Windows 10 on a Dell XPS 13. I created a bootable USB drive with the Mint 17.3 iso using Rufus. I have been able to boot from the drive but haven't been able to use it to install Linux on the system itself.

I've read some conflicting advice around the web regarding setting the bios in UEFI or legacy mode and enabling or disabling secure boot. For instance, one thread I found said (if I understood correctly) that I should install Linux using the same setting as my Windows partition. This would mean the partition should boot using UEFI, however I have only been able to install Mint using legacy boot mode. When I tried to access this partition it would not load past the splash screen with the Mint logo.

I've been able to run Linux from the USB in UEFI mode, however when I run the installer to put it on the system I am told I don't have enough space:

not enough space

I have freed up roughly 90 GB by shrinking my windows partition, so I don't understand why the installer isn't detecting that space. I suspect it might be trying to install Linux on the USB, but I don't know how to confirm or change that setting. Here is a picture of my partitions in Windows to confirm I actually have the free space:

free space

Why isn't the installer detecting the free space on my drive, and how can I fix the issue so a can dual boot with Windows and Linux? What boot settings should I use for the smoothest install?

  • 1
    You are not allowed to use more than 4 partitions on the Master Boot Record. – GAD3R May 13 '16 at 21:58
  • If I am understanding your comment correctly, I think I should clarify that the disk uses GPT partition style rather than MBR. – Brisanth May 13 '16 at 23:50
  • Similar unanswered questions here and here. – steel Jul 22 '18 at 4:30
-1

Your screenshot shows the 93.60G Unallocated partition quite clearly so it is detecting it. Why this is not reflected in the upper portion of that installer window I can only speculate on.

I would guess that is only a list of allocated partitions.

Did you click on that partition in the screen you have pictured?

Without downloading and checking the LM installer out it is pretty hard to give you more help.

I think they may have a link on their live session to installation documentation. Many installers themselves have links to release notes that can be very informative.

I suggest checking those resources out. Linux Mint has a good reputation for good documentation. Have you checked their site? They also have a very good forum.

Definitely check here; https://linuxmint.com/documentation.php

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.