0

I was trying to set the alias for command:

{cutadapt -O 24 -q 19,19 -m 30 -g TATAGAATTCGCGGCCGCTCGCGATAATACGACTCACTATAGGGCGTTTTTTTTTTTTTTTTTTTTTTTT -g TATAGAATTCGCGGCCGCTCGCGATTTTTTTTTTTTTTTTTTTTTTTT -g GTATAGAATTCGCGGCCGCTCGCGAT -a CGCCCTATAGTGAGTCGTATTATCGCGAGCGGCCGCGAATTCTATA -a ATCGCGAGCGGCCGCGAATTCTATAC'
} 

so added this into my .cshrc file:

alias cutqtzPro_RT 'cutadapt -O 66 -q 18,18 -m 25 -g TATAGAATTCGCGGCCGCTCGCGATAATACGACTCACTATAGGGCGTTTTTTTTTTTTTTTTTTTTTTTT'

and sourced the .cshrc

source .cshrc

but it didn't work. shell could not find "cutqtzPro_RT" as a command.

This link seems to suggest to use double quote instead of single quote in the csh. I tried both, none of them worked.

Any idea or suggestion? I am using c shell.

  • what is the output of alias command? also output for this command which cutqtzPro_RT – Sundeep May 13 '16 at 8:45
  • 1
    this means csh still hasn't recognized the alias.. can you try add the alias directly on your terminal and then check if it works (just copy paste the alias command from your .cshrc) – Sundeep May 13 '16 at 8:52
  • 4
    Because the ~/.cshrc is interpreted(i.e. source) as line by line, so if one of your alias have wrong format/syntax, then it will stop, but doesn't change the fact of first line has been successfully alias in current session. You should double check you other alias in ~/.cshrc. – 林果皞 May 13 '16 at 9:10
  • 2
    @林果皞, oh, then I guess this issue was caused by the line: setenv NGSPLOT $HOME/Tool/ngsplot:$NGSPLOT, "NGSPLOT" is an environment variable required by a R package "ngsplot", I added a line in the cshrc, everytime I log in the system, I got complain "NGSPLOT" as a variable not defined. whenever I need to run ngsplot, I have claim NGSPLOT as an environment variable by command. so I guess csh have problem with that line, and stop there. Thanks! – Jun May 13 '16 at 9:19
  • 2
    @spasic. Hi, I guess the issue was as 林suggested, there was a line with syntax error, and csh just stuck thereafter. Tsk! – Jun May 13 '16 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.