3

I'm trying to install my TP-LINK AC 600 (T2UH) wireless USB adapter on my Raspberry Pi 3b running Raspbian Jessie Lite.

I was following a guide for Ubuntu but it looks like i'm missing something but I don't know what.
Below are the steps I followed (without success):

sudo apt-get install git build-essential
git clone https://github.com/Myriade/mt7610u_wifi_sta_v3002_dpo_20130916.git
cd mt7610u_wifi_sta_v3002_dpo_20130916
make <-- failed
sudo make install
sudo cp RT2870STA.dat /etc/Wireless/RT2870STA/RT2870STA.dat

Error when running make:

make[1]: /lib/modules/4.1.19-v7+/build: No such file or directory. Stop. Makefile:403: recipe for target 'LINUX' failed make: [LINUX] Error 2

I also tried to run sudo apt-get install linux-headers-generic but I ran into the error Package 'linux-headers-generic' has no installation candidate but I'm not sure if I need this?

Output of lsusb:

Bus 001 Device 004: ID 148f:761a Ralink Technology, Corp. 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Can somone please help me get this Wireless USB to work?

UPDATE

As requested, here is my sources.list :

deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi
3
  • I'm running the latest Raspbian Lite, which is Jessie.
    – user170037
    Commented May 12, 2016 at 9:51
  • Can you add the content of your sources.list
    – GAD3R
    Commented May 12, 2016 at 9:54
  • Done, see the update above.
    – user170037
    Commented May 12, 2016 at 10:09

3 Answers 3

1

I had the same issue. I solved it in 3 steps:

  1. Get the source code for linux from Tp-link website (source code)
  2. Get the right source code of the kernel in use. This very good tutorial was a great help: https://github.com/notro/rpi-source/wiki
  3. Look up in the Makefile in the source code from tp-link, to set up the right platform to compile and fix some minor compiling issues in the source code.

Then continue the tutorial to install the compiled module.

It works fine in 2.4Gz so far.

1
0

I got the adapter to work on my Raspberry Pi 3, though it was not easy.

The challenge is that the source code from TP-Link is rather old. They mark it as "Kernel version 2.6~3.16". While Raspbian Jessie is 4.9+

There are several repos on github that have updated versions of the driver source for newer kernels. However not all of those compile. And some even if they compile failed to work.

I tried three different repos but in the end only https://github.com/xtknight/mt7610u-linksys-ae6000-wifi-fixes worked for me. You can follow the repo's README.MD for instructions on how to compile.

0

This is how I solved it.

Items used:

  • TP-Link Nano USB Wifi Adapter- AC600 2.4G/5G Dual Band Wireless Network Adapter for Desktop PC (Archer T2U Nano)
  • Raspberry Pi 3 A+
  • uname -r: 5.10.63-v7+
  • lsusb: Bus 001 Device 004: ID 2357:011e TP-Link
  • Raspberry Pi OS Lite (32-bit) 2021-05-07

Some of these commands took several minutes to run, over 10 minutes for a couple of them.

sudo apt-get install -y raspberrypi-kernel raspberrypi-kernel-headers  # slow

git clone https://github.com/aircrack-ng/rtl8812au.git
cd rtl8812au

sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' Makefile
sed -i 's/CONFIG_PLATFORM_ARM_RPI = n/CONFIG_PLATFORM_ARM_RPI = y/g' Makefile
sed -i 's/CONFIG_PLATFORM_I386_PC = y/CONFIG_PLATFORM_I386_PC = n/g' Makefile
sed -i 's/CONFIG_PLATFORM_ARM64_RPI = n/CONFIG_PLATFORM_ARM64_RPI = y/g' Makefile
make  # slow

sudo make install
sudo modprobe 88XXau

After that running ip a showed the new wireless adapter. Reboot not needed. After rebooting the adapter kept showing up and working.

For posterity I was on git branch v5.6.4.2 in that repo:

commit b8167e66b4ac046b3b76c2c40008d84528e91594 (HEAD -> v5.6.4.2, origin/v5.6.4.2, origin/HEAD)

You must log in to answer this question.