0

I previously used ubuntu, I can set a image as my terminal background. Yet, in centos 7, I don't see a place for setting image as the terminal background. What can I do to achieve this?

It's interesting that cento7 have the gnome as GUI, just like ubuntu, how come their terminals is different?

  • Ubuntu by default uses Unity, not GNOME. AFAIK it is possible to use GNOME on Ubuntu, but not Unity on CentOS. Check your assumptions; are you sure you were using GNOME on your Ubuntu box? (Also, welcome to the site!) :) – Wildcard May 12 '16 at 2:39
  • er..I am not sure now..I use to think Unity is part of GNOME.. :) – Allan Ruin May 12 '16 at 7:28
1

Apparently this was once a feature of GNOME-terminal, but as part of a code cleanup, the feature was dropped somewhere at or before v3.14.2. As such, it is no longer an option in current versions of the application.

  • Yup, it was dropped in 3.14. – egmont May 12 '16 at 15:01
0

To keep things consistent between distros, I use Terminator. This way settings can be synced between systems as long as the versions are not very different. Backgrounds, transparency, multiple panes and layouts are extras that some terminals don't offer.

  • As DopeGhoti said, (which I also found out in other posts) GNOME terminal no longer have the background option, So I guess I must switch to Terminator. <del>That's still a little problem, I used yum install terminator but it did not found the package..</del> ,I missed the instruction, should add RPMFORGE source first. – Allan Ruin May 12 '16 at 7:37
  • I strongly advise against using Terminator's default (gtk2) branch (and the new gtk3 branch doesn't support background image either). It uses a much older VTE widget for terminal emulation, one that suffers from plenty of bugs (including serious ones) and is no longer maintained. By using gnome-terminal (or Roxterm, Terminator's gtk3 branch, Terminix, etc., all using newest VTE) you do lose transparency, but get a significantly better behavior in many other aspects. – egmont May 13 '16 at 5:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.