9

If I want to get a brief usage message for a bash builtin, I can use help <builtin> at a command prompt, e.g.

$ help export
export: export [-fn] [name[=value] ...] or export -p
    Set export attribute for shell variables.

    Marks each NAME for automatic export to the environment of subsequently
    executed commands.  If VALUE is supplied, assign VALUE before exporting.

    Options:
      -f        refer to shell functions
      -n        remove the export property from each NAME
      -p        display a list of all exported variables and functions

    An argument of `--' disables further option processing.

    Exit Status:
    Returns success unless an invalid option is given or NAME is invalid.

How can I do this in zsh? I've tried

% export --help
zsh: bad option: -e

and

% help export
zsh: command not found: help

Also the word "help" isn't anywhere in man zshbuiltins.

5

thanks to @don_crissti linking through this Arch wiki documentation.
For some reason the code on the Arch wiki causes this error on invocation

/home/velour/.zshrc:unalias:368: no such hash table element: run-help

zsh --version => zsh 5.1.1 (x86_64-ubuntu-linux-gnu)

so to get it to work, I added the below block to ~/.zshrc, then commented out the alias commands.

autoload -Uz run-help
autoload -Uz run-help-git
autoload -Uz run-help-svn
autoload -Uz run-help-svk
#unalias run-help
#alias help=run-help

and simply invoke with

run-help <builtin>

So now I get

% run-help export

export [ name[=value] ... ]
       The specified names are marked for automatic export to the envi-
       ronment  of subsequently executed commands.  Equivalent to type-
       set -gx.  If a parameter specified does not already exist, it is
       created in the global scope.
  • @don_crissti I have updated my answer with details of error and zsh version. – the_velour_fog May 12 '16 at 0:40
  • Maybe it's this – don_crissti May 12 '16 at 0:48
  • 4
    I tried this without uncommenting out the aliases, and I just get the zshbuiltins manual page. How can I get help for a specific builtin without searching for it in there? – addison May 30 '16 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.