0

Three days ago, I tried installing the second of two Ubuntu Linux 16.04 versions side by side on the same Lenovo Thinkstation desktop using the procedure described in this URL, https://askubuntu.com/questions/13977/dual-booting-two-ubuntu-versions.

When the installation finished, I got the console message, "The installation completed successfully. Please restart the system."

When I restarted the Lenovo Thinkstation computer desktop, it asked me create new user which I did. But I lost the former user, linux3 , from the first Ubuntu Linux 16.04 instance by inadvertently deleting libc.so.6 in the old first instance.

I lost the user, linux3 , from my Ubuntu Linux 16.04 instances because I can no longer login after rebooting my Ubuntu Linux 16.04 instance, even after I selected the partition(s) corresponding to the old Ubuntu instance in grub2 because I mistakenly "sudo" deleted the soft link, libc.so.6 , and libc-2.23.so in the subfolder /lib/x86_64-linux-gnu.

Here is the error message when rebooting the Ubuntu Linux 16.04 instance halts prematurely.

/sbin/init: error while loading shared libraries: libc.so.6 cannot open shared object file: No such file or directory [14.578123] Kernel panic: --not syncing : Attempted to kill init! exitcode=0x00007f00`

I was hoping for a critique of these two possible ways to regain access to the user , linux3 , and all the files and directories associated with it such as /lib by using an USB drive which contains libc.so.6 and libc-2.23.so and copying the the soft link, libc.so.6 , and libc-2.23.so over to the subfolder /lib/x86_64-linux-gnu from grub2 recovery mode.

Otherwise, how might I do this using my side by side Ubuntu Linux 16.04 instance in another partition with username , siblings?

Any help is greatly appreciated.

7
  • I would assume this now boots into the new instance by default. Have you selected the old instance in grub and then tried to login with the linux3 user?
    – Anthon
    May 11, 2016 at 10:38
  • @Anthon, Thank you for your comment just now. How do I select the old instance in grub? I may have clobbered it by inadvertently deleting libc.so.6 in the old instance. May I ask how to replace the deleted libc.so.6?
    – Frank
    May 11, 2016 at 10:57
  • During your startup, if you don't get the grub selection menu, you might need to press some key to get into that menu. I haven't got 16.04 installed and don't know if there is a secret combination. Once you can select you might recognise the other installation based on the partition it is installed on.
    – Anthon
    May 11, 2016 at 11:32
  • @Anthon, Thank you for your comment on selecting the partition in the Ubuntu grub selection menu. Have you used the --sysroot or -rpath-link features in the arm-linux-gnueabi-g++ compiler and linker for Ubuntu Linux?
    – Frank
    May 11, 2016 at 12:24
  • @Anthon, I just read this URL , stackoverflow.com/questions/12249547/…, and wollud1969 says: "Boot using a live cd like Knoppix or whatever and fix the missing link after mounting the disk with the "broken" system out of the running live system." Thank you,
    – Frank
    May 11, 2016 at 19:16

1 Answer 1

0

Here is how I repaired the inadvertent mistake of deleting libc.so.6:

  1. Reboot the good Ubuntu Linux 14.06 instance, /dev/sdb6

  2. Go to GRUB2 read-write recovery or rescue mode followed by selecting root shell prompt.

  3. sudo mount /dev/sda1 /mnt

  4. cd /mnt/lib/x86_64-linux/gnu

  5. sudo ln -s libc-2.23.so libc.so.6

  6. exit

  7. Reboot the formerly corrupted Ubuntu Linux 14.06 instance, /dev/sda1.

  8. Now, both Ubuntu Linux 14.06 instances are fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .