0

I want to run genymotion 64bit binary on my debian 8.3 64bit. when I run ./genymotion command I get this error:

./genymotion: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory

I followed the command that mentioned in here but I get this error (how ever he tried that in ubuntu):

╰─$ sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev                                            100 ↵
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgstreamer-plugins-base0.10-dev : Depends: libglib2.0-dev but it is not going to be installed
 libgstreamer0.10-dev : Depends: libglib2.0-dev but it is not going to be installed

E: Unable to correct problems, you have held broken packages.

how can I solve this issue ?

1

Assuming your immediate issue is running genymotion, this should be enough to fix the first error you reported:

sudo apt-get install libgstreamer-plugins-base0.10-0
  • @noobninja you should ask a new question to cover your specific case. – Stephen Kitt Oct 30 '16 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.