When switching to a virtual terminal using e.g. Ctrl+Alt+F2, it takes about a second to switch. Not too horrible for something that's typically rarely used, but I would like to use it more and it's substantially slower than, say, Alt+Tab. It's particularly weird since switching back to the desktop environment (Alt+F7 for me) is instant.

I've noticed it before, but currently I'm running Debian testing (Stretch) with Cinnamon 2.8.7 on X 1.18.3. The resolution of the virtual terminal is the same as X's resolution.

What is this delay caused by and how can I improve it?

  • Works pretty great for me :). You need to say what software + hardware you're using! – sourcejedi May 11 '16 at 8:17
  • @sourcejedi Hmm I've noticed it on every Linux-based OS ever, but I'll include that. – Luc May 11 '16 at 9:20
  • My "good" system is Fedora 23 on Thinkpad X201, and it just feels instant. The resolution is the same on X (xdpyinfo) & console (fbset). Pre-KMS, you tended to suffer long mode-changes switching either way. Exception: switching to gdm (which has its own VT) flickers once - it does take about a second overall but nothing more than that. I don't know the root cause, but I note that gdm (on Fedora) is different in that it runs as Wayland instead of X. – sourcejedi May 11 '16 at 9:36
  • @sourcejedi I also run X (added the info to the post) and the resolution is also the same. If it wasn't I think I'd also have a delay switching back from the vt to the desktop environment. – Luc May 11 '16 at 10:21
  • what GPU and driver are you using? i have nvidia cards using the proprietary nvidia driver, and also have delays of over a second when switching from X to VT and vice-versa....annoying, but I don't do it often so it's not a big deal for me. – cas May 11 '16 at 10:43

The X server manages the state of the graphics card when it's active. When you switch between X and a text console or back, the graphics card needs to be reinitialized. Depending on the graphics card and on how it's used, there may be an unavoidable delay. A 1s delay is on the high side but not unreasonable.

Few people use a text console, so even if it was possible to improve the transition time (which it might not be), this isn't a high priority for developers.

If this delay is really a problem, try changing the driver or the configuration in X, in text consoles or both. If you're using a proprietary driver, use the free driver, or vice versa. If you're using a framebuffer console, don't, or vice versa. Some options that can affect what needs to be reinitialized when the console switches owners; I don't know what to look for in particular.

  • How/to what would I change the "framebuffer console"? Searching for "virtual console no framebuffer" and "switch framebuffer console" yield no good results it seems (at least on DDG). – Luc May 12 '16 at 6:22
  • 1
    @Luc There are multiple ways to parametrize the console. At least the vga=… and fbcon=… kernel parameters, /etc/default/console-setup. I haven't really use VGA consoles for a long time so I don't know the modern ways. – Gilles 'SO- stop being evil' May 12 '16 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.