i'm having extreme difficulty trying to install CentOS 7 on a HP Z640 Workstation,

Specs http://www8.hp.com/h20195/v2/GetPDF.aspx/c04400040.pdf

I have tried installing CentOS 7 and 6.7 in UEFI and both stall at the same time.

"Waiting for hardware to initialize"

If i install using Legacy the installer goes through all of the steps, and appears to install fine, but once i reboot the SSD has no OS installed on it.

I've tried installing the Minimal and LiveDVD version, bootbale usb and a bootable dvd.

Any advice is appreciated!

  • Did you have a pre-installed OS on your PC? – GAD3R May 9 '16 at 10:41
  • Originally had windows 7 Pro 64-bit – RyanIG May 9 '16 at 10:55
  • Turn off the secure boot on your BIOS settings – GAD3R May 9 '16 at 11:00
  • Just checked there and Secure boot was already disabled – RyanIG May 9 '16 at 11:03
  • Create a new partition bios_grub size=1 mib and try to reinstall your OS Legacy – GAD3R May 9 '16 at 11:21

you might be suffering from a problem i ran into in the past on some hp latop when I tried installing mint. Try disabling legacy support and then boot into centos and execute grub-install.

  • Sorry for the late response but this sort of worked, after disabling it i couldn't boot at all but once i re-enabled it the install worked fined, no idea why it was causing an issue though! – RyanIG May 11 '16 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.