0

I am trying to build some C programs in beaglebone black (using debian) which I git clone from here. Now I try command make I got this error :-

Makefile:9: *** "https://github.com/x42/libltc version >= 1.1.0 is required - install libltc-dev".  Stop.

So , I decide to install libltc-dev and try this

 apt-get install libltc-dev

But I got this error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libltc-dev

I google this error, but there is hardly any thing available about libltc-dev. So, can anyone tell me how to install libltc-dev.

  • Which version of Debian are you using? (cat /etc/debian_version if you don't know.) – Stephen Kitt May 9 '16 at 7:11
  • i am using debian 7.9 – tabish May 9 '16 at 7:12
  • libltc-dev is present in jessie (8.x) but not in wheezy – Rui F Ribeiro May 9 '16 at 7:16
1

libltc is available in Debian 8, but not in Debian 7.

The version of the package in Debian 8 has dependencies that can all be satisfied in Debian 7 on armhf, so it may be possible to install that version:

wget http://ftp.debian.org/debian/pool/main/libl/libltc/libltc-dev_1.1.4-1_armhf.deb http://ftp.debian.org/debian/pool/main/libl/libltc/libltc11_1.1.4-1_armhf.deb
sudo dpkg -i libltc-dev_1.1.4-1_armhf.deb libltc11_1.1.4-1_armhf.deb

If that fails, the build dependencies can also all be satisfied in Debian 7, so it should be possible to build the current package using Debian 7 on your BB:

sudo apt-get install devscripts build-essential
dget http://httpredir.debian.org/debian/pool/main/libl/libltc/libltc_1.2.0-1.dsc
cd libltc-1.2.0
dpkg-buildpackage -us -uc

That should produce the .deb files in the parent directory; you can then install them using dpkg -i.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.