0

So I have two nics, but I can't get the second to load, here is the output from

lspci -vvv


04:00.0 Ethernet controller: Intel Corporation 82574L Gigabit Network Connection
    Subsystem: Super Micro Computer Inc Unknown device 0000
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 169
    Region 0: Memory at fb900000 (32-bit, non-prefetchable) [size=128K]
    Region 2: I/O ports at e000 [size=32]
    Region 3: Memory at fb920000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: [c8] Power Management version 2
            Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
            Status: D0 PME-Enable- DSel=0 DScale=1 PME-
    Capabilities: [d0] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
            Address: 0000000000000000  Data: 0000
    Capabilities: [e0] Express Endpoint IRQ 0
            Device: Supported: MaxPayload 256 bytes, PhantFunc 0, ExtTag-
            Device: Latency L0s <512ns, L1 <64us
            Device: AtnBtn- AtnInd- PwrInd-
            Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
            Device: RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
            Device: MaxPayload 128 bytes, MaxReadReq 512 bytes
            Link: Supported Speed 2.5Gb/s, Width x1, ASPM L0s L1, Port 0
            Link: Latency L0s <128ns, L1 <64us
            Link: ASPM Disabled RCB 64 bytes CommClk+ ExtSynch-
            Link: Speed 2.5Gb/s, Width x1
    Capabilities: [a0] MSI-X: Enable+ Mask- TabSize=5
            Vector table: BAR=3 offset=00000000
            PBA: BAR=3 offset=00002000

I found out to use Intels e1000e drivers but when I use make install, I get the following:

[root@lan3 src]# make install
Makefile:67: *** Kernel header files not in any of the expected locations.
Makefile:68: *** Install the appropriate kernel development package, e.g.
Makefile:69: *** kernel-devel, for building kernel modules and try again.  Stop.
[root@lan3 src]#


[root@lan3 src]# yum install kernel-devel
Loaded plugins: fastestmirror, kmod
Loading mirror speeds from cached hostfile                                                * addons: centos.mirror.nac.net
 * base: centos.chi.host-engine.com
 * extras: mirror.metrocast.net
 * updates: mirror.trouble-free.net
Setting up Install Process
Package kernel-devel-2.6.18-409.el5.x86_64 already installed and latest version
Nothing to do
[root@lan3 src]#

Changing OS's is not an Option, I realize its old, but its a standard Intel Gigabit Nic. Any help is appreciated!

UPDATES:

# uname -r
2.6.18-194.11.1.el5

ifconfig doesn't show the NIC at all.

  • Please display output of ifconfig command and lsmod commad output – Yasan C May 9 '16 at 10:22
  • What does uname -r say? – schaiba May 9 '16 at 10:45
  • Updated with outputs – FreeSoftwareServers May 10 '16 at 15:42
0

The solution!

Install elrepo repository. && install kernel independant e1000e drivers from elrepo && tell kernel to use new drivers && reboot.

rpm -Uvh http://www.elrepo.org/elrepo-release-5-5.el5.elrepo.noarch.rpm && yum install kmod-e1000e && sudo nano /etc/modprobe.conf && reboot

Replace

#alias eth0 e100e
alias eth0 kmod-e1000e

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.