2

I'm getting fuse errors when trying to install packages with apt-get. I've tried reinstalling it but it didn't help.

This is output when I try to install something:

Do you want to continue? [Y/n] y
Setting up fuse (2.9.3-15+deb8u2) ...
Creating fuse device...
/run/udev or .udevdb or .udev presence implies active udev.  Aborting MAKEDEV invocation.
chmod: cannot access '/dev/fuse': No such file or directory
dpkg: error processing package fuse (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 fuse
E: Sub-process /usr/bin/dpkg returned an error code (1)

3 Answers 3

6

Hey its very simple to fix:

mkdir /dev/fuse
chmod 777 /dev/fuse

apt-get install fuse
1
  • 1
    This solution worked surprisingly well. I don't see why it was downvoted. I had the same problem, and simply by creating the dir with those perms, the fuse install problem went away.
    – Scott
    Jul 28, 2017 at 0:54
0

This is potentically a duplicate of "E: Sub-process /usr/bin/dpkg returned an error code (1)" when I try and install OpenVPN. What is this?: a package tried to install fuse (probably as a dependency), however the configuration of the package failed since udev did not create /dev/fuse.

You might check the output of $ service udev status to see whether the service is running and $ modinfo fuse to verify that the kernel module exists.

If you are running inside a VM that shares a kernel with the host, chances are your VM is not allowed to use FUSE.

To get rid of the error, apt-get remove fuse.

Hth, dtk

0

This worked very well for my Pi Model B+ V1.2 running Raspbian GNU/Linux VERSION=8 (jessie).

  • I only had to do:

    mkdir /dev/fuse
    chmod 777 /dev/fuse
    

    since my system already had fuse in it's latest version

1
  • In my case must remove this file, then run apt install --reinstall ntfs-3g
    – EsmaeelE
    Mar 27, 2020 at 0:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.