0

I have just scrapped Linux Mint 16 for Manjaro (kernel 4.1.15) on my Dell Latitude 6530. I have installed NVidia proprietary drivers in the hope resume from hibernate would work. It does but now I'm facing other issues, such as brightness control.

I've checked Arch Wiki for a solution and the only option they give is xorg-xbacklight. Unfortunately it doesn't work either.

I've tried writing values to /sys/class/backlight/acpi_video0/brightness but brightness doesn't change. Indeed, as hinted in the Wiki, the ACPI value changes but brightness doesn't. I then tried xbacklight but still no change.

EDIT: I have also tried keeping the [native brightness control] with kernel argument video.use_native_backlight=1. Still no luck... except that backlight seems to have gotten dimmer. Coincidentally I had set /sys/class/backlight/acpi_video0/brightness to 50% before rebooting my laptop.

I know brightness control does work because it did with Linux Mint 16 — ok, that was a rather old kernel, i.e. 3.11 or something. NVidia drivers were also the proprietary ones, version 304.

Any hint or suggestion?

0

The backlight issue seems to have many potential sources. Mine was just about enabling backlight control with nVidia proprietary driver in Xorg configuration. This answer on Ubuntu stack exchange did the trick:

Section "Device"
Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    ...
    # Added the following option:
    Option         "RegistryDwords" "EnableBrightnessControl=1"
EndSection

After login out and then back, backlight control keys worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy