0

I can wake up ubuntu server 16.04 from my iphone using WOL. I tried to do the same thing from mac osx yosemite. couldn't get it work.

first I installed wakeonlan. "brew install wakeonlan"

then I ran "wakeonlan -i 192.168.1.166 -p 9 bc:2f:f9:c8:c1:e5". nothing happened and no error message.

its using port 9. do I need to open this port? on my iPhone, its also using port 9, I dont have to do anything, it just works. What else do i need to check?

Updates:

mac osx didn't have this file. but ubuntu server 16.04 has it.

qinking126@nas:~$ cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
CIR   S3    *disabled
PS2K      S4    *disabled
PS2M      S4    *disabled
UAR1      S4    *disabled  pnp:00:07
USB1      S3    *disabled
RP01      S4    *disabled  pci:0000:00:1c.0
RP02      S4    *disabled
RP03      S4    *disabled
RP04      S4    *disabled  pci:0000:00:1c.3
BR40      S4    *disabled  pci:0000:02:00.0
RP05      S4    *disabled
RP06      S4    *disabled
RP07      S4    *disabled
RP08      S4    *disabled
GLAN      S4    *enabled   pci:0000:00:19.0
EHC1      S4    *enabled   pci:0000:00:1d.0
EHC2      S4    *enabled   pci:0000:00:1a.0
XHC   S4    *enabled   pci:0000:00:14.0
HDEF      S4    *disabled  pci:0000:00:1b.0
PEG0      S4    *disabled
PEGP      S4    *disabled
PEG1      S4    *disabled
PEG2      S4    *disabled
  • Please add to your question the output of cat /proc/acpi/wakeup ;) – John WH Smith May 8 '16 at 12:51
  • @JohnWHSmith, I added it to my question. – qinking126 May 8 '16 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.