9

On my Linux Mint 17.2 Cinnamon system, ALT+TAB switcher, in the default settings (icon and thumbnail pop up in the switcher) shows a pixelated icon for one of my applications. I do not know where the icons are loaded from, and as a result I do not know how to fix this.

So where are the ALT+TAB icons loaded from into memory for the ALT+TAB switcher to use, and how can I resolve this issue of a low-resolution icon being loaded?

5

These icons are generally located in the /usr/share/icons/hicolor/<resolution>/apps/ directories. <resolution> corresponds to each resolution available: for instance, 22x22 or 128x128.

You can see what icon resolutions are available for your particular program using this command:

find /usr/share/ -name <application>.png

Here, replace <application> with the name of the executable for the program in question. This can be verified using the which command:

$ which google-chrome
/usr/bin/google-chrome
$ which chrome
$

For instance, these are the icons available for Chrome on my system (ran from /usr/share):

$ find . -name google-chrome.png
./24x24/apps/google-chrome.png
./64x64/apps/google-chrome.png
./22x22/apps/google-chrome.png
./256x256/apps/google-chrome.png
./128x128/apps/google-chrome.png
./48x48/apps/google-chrome.png
./32x32/apps/google-chrome.png
./16x16/apps/google-chrome.png

Possible solutions:

  1. If you don't have high resolution versions of these icons, you could try an answer suggested here and simply create them with the GIMP image manipulator using Image -> Scale. Then, place the new icons in the particular directories.

  2. If high resolution versions are present here but you still see a pixelated image when you ALT + TAB, you can try the second answer from the previous link:

    Add StartupWMClass=<application> to the application's .desktop file within the /usr/share/applications directory.

    So for this example using google-chrome, I would add

    StartupWMClass=google-chrome

    to the /usr/share/applications/google-chrome.desktop file.

1

I'm aware of the age of this question and anyway I will provide my answer for future reference, as the one posted by @clk didn't resolve the issue for me on kde Plasma 5.2, which task switcher (ALT+TAB) was showing blurry icons for some applications, e.g. Gimp and Emacs.

In that regard I double checked the StartupWMClass key/value within the <application>.desktop file, both:

  • /usr/share/applications/<application>.desktop
  • /home/<user>/.local/share/applications/<application>.desktop.

The WM_CLASS for the app was already set to the right one, that is, the string given in output of the xprop command applied to the specific window of the app with blurry icon.

I also checked to have good resolution icons within /usr/share/icons/hicolor/<resolution>/apps/ and that was not the case as hi-res icons where already there.

Simple solution tested with KDE Plasma

  1. open the the application with blurry icon
  2. click on the title bar of that window
  3. choose more actions->application settings. This will open a dialog with some specific setting for the application window.
  4. bottom left of the dialog, click add property, scroll down and choose name of the desktop file, from the dropdown choose force and within the text field, add in the name for the specific application (<application>.desktop).
  5. click apply

The task switcher should now use the right high-resolution icon for the application.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.