1

Alright, so I did a very stupid thing the other day. I was building a python program in pycharm, and I wanted to see what the UI looked like in the terminal. So I tried to run the code, but I didn't work because python 2.7 was installed not python 3.5. So my brain at 2 am decided that It would delete python 2.7 and install python 3.5, but at the time I didn't realize that linux mint was dependant on python... so I removed it.

I don't know how much was deleted but it paused to ask me whether I preferred mdm or lightdm. I (with no real linux experience) panicked and decided that I would reboot, and hope in the reboot process that Linux mint would realize that packages were missing automatically download and restore them. Wrong, I just got stuck on the logo it the boot screen. Then I rebooted Linux mint recovery. Ran aptitude -f, it showed some packages recommended to install and I pressed g to install them. Then I ran dpkg. It installed a few. I tried to reboot into Linux Mint but it still wasn't working.

So after googling I ran across debsums and so I did what the forum told me to do and It fixed all my corrupted and missing files. Still wasn't working. After googling more I ran into aptitude --reinstall '-i' (Which would reinstall all packages) but it requires aptitude v0.7.3 and I have v0.6.8.2. When I try to apt-get install aptitude, it claims that aptitude is already at the newest version.

As of right now when I reboot the Ubuntu 17.2 logo pops up instead of the Linux Mint, but the computer still boot-loops.

Can I fix this without losing my data? I would rather fix it than reinstall Linux Mint if possible.

  • Do you remember how exactly did you remove python? I mean with python* regex for example, for me to be able to simulate a few scenarios in a VM? – LinuxSecurityFreak May 7 '16 at 17:46
  • I did apt-get remove python I then typed the Yes, do as I say! – Pythogen May 7 '16 at 18:06
  • Not that this is particularly helpful, but hopefully you're learned the lesson that if you're not only asked if you're sure, but have to show just how sure you are, you might want to make certain you're fully awake before telling the system you're really really surely sure. – DopeGhoti May 7 '16 at 18:10
1

This is what happened in a VM to me when removing regex python*:

enter image description here

Since I can't figure out how to install all of it back in, it will be hard to put it together.

I will not poke you further, you have learned lesson the hard way. Maybe is someone able to fix it, but I doubt it will be faster than a clean install. That is why I post this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.