I installed CentOS 6.X with VMWare Fusion.

It looks like the mac address and nic names changes randomly.

enter image description here

eth8 and eth9, totally weird.

Anyone know why?

P.S VMWare pops a dialog asks me if I moved or copied the VM, although I never did anything to the Virtual Machine. And each time I choose I moved it, maybe it's relevant to the problem?

P.P.S I also have other Linux VMs, e.g Ubuntu which never had such problems, Hmm.

  • vmware assigns the MAC address(es) to the VMs. check your vmware config.
    – cas
    May 7, 2016 at 13:18
  • @cas so how can I prevent this from changing?
    – daisy
    May 7, 2016 at 13:30
  • i have no idea. it's a vmware problem, not a unix or linux problem. check your vmware config. see also google.com/search?q=vmware+mac+address
    – cas
    May 7, 2016 at 13:59

1 Answer 1


According to vmware-support You need to assign the MAC adress manually to avoid changes in the MAC automatically evrytime you moved it.

If you want to guarantee that the same MAC address is assigned to a given virtual machine every time, even if the virtual machine is moved, or if you want to guarantee a unique MAC address for each virtual machine within a networked environment, you can assign the address manually instead of allowing VMware Workstation to assign it automatically.

To assign the same, unique MAC address to any virtual machine manually, use a text editor to remove three lines from the configuration file and add one line. The configuration file has a.vmx extension at the end of the filename. On a Linux host, a virtual machine created with an earlier VMware product may have a configuration file with a .cfg extension.

As it's described:

Remove the three lines that begin with the following from the configuration file:


In these options, [n] is the number of the virtual Ethernet adapter — for example ethernet0.

Add the following line to the configuration file:

ethernet[n].address = 00:50:56:XX:YY:ZZ 

Or you can edit the file like the following example:

ethernet[n].addressType = "static"
ethernet[n].checkMACAddress = "false"
ethernet[n].address = "00:50:56:XX:YY:ZZ"
  • 1
    Thanks! It works. Do you also know how to reset nic names like eth10 to eth0?
    – daisy
    May 7, 2016 at 15:38
  • Save the file /etc/sysconfig/network-scripts/ifcfg-eth10 and create a new one for eth0 , Open /etc/udev/rules.d/70-persistent-net.rules chage eth10 by eth0
    – GAD3R
    May 7, 2016 at 15:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .