I have a media center pc with a discrete gpu (AMD Radeon R9 270x) and a internal intel graphics and I have some problems with the HDMI-audio output when using ALSA and the Radeon card. HDMI audio from my internal gpu is working fine. The reason for using a powerful gpu is to be able to do some gaming.

I had GPU offloading (PRIME) working using xorg display server, but noticed some artifacts when gaming using the Radeon card. Now I would like to test Weston with XWayland on the internal gpu and use the radeon card to render the more demanding games.

My understanding is that it is possible to use gpu offloading with wayland. What I don't seem to understand is how to enable the offloading from a wayland session. Is it as simple as setting DRI_PRIME=1? I would imagine that I need some more configuration.

Thanks in advance :)


My system is fedora27,gnome on wayland,and I add "export DRI_PRIME=1" to my "~/.profile" file. It works well with my amd HD8730M card.

For more information,you can visit this website: https://archive.fosdem.org/2014/schedule/event/wayland_gpu/attachments/slides/364/export/events/attachments/wayland_gpu/slides/364/GPU_offloading.pdf

This is a PPT about gpu offloading on wayland.

  • 1
    Also, that powerpoint is about 4 years old at this time, are you sure it's up to date? – telcoM Jan 20 '18 at 18:00
  • I tested it on my fedora27, and it works well. – godcrying Jan 21 '18 at 16:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.