0

I found this article and seem to have a similar Problem. Why is USB not working in Linux when it works in UEFI/BIOS?

MyConfig Fujitsu Board Qxx Chipset i5-2400

I use VPro KVM and the input doesn't work in debian jessie. Live CD and rescue mode are fine.

I tried an upgrade to Kernel 4.5.

To get network back to work I used service restart network-manager in rescue mode.

Normal usb devices work again after replugging them.

I changed mainboard and CPU recently, but I had similar problems with the last system. I don't have a Gigabyte board. And tried nearly all settings in bios.

Following the lsusb output. 001:004 must be the vPro KVM.

lsusb :

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 046d:c529 Logitech, Inc. Logitech Keyboard + Mice
Bus 001 Device 004: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

just the dmesg | grep '2-3'. The vPro KVM device.

[    4.284230] usb 2-3: new high-speed USB device number 3 using ehci-pci
[    4.491046] usb 2-3: New USB device found, idVendor=8086, idProduct=002b
[    4.491051] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    4.491061] usb 2-3: Product: USBr Composite Device
[    4.491063] usb 2-3: Manufacturer: Intel
[    4.491065] usb 2-3: SerialNumber: 0001
[    5.921587] usb 2-3: USB disconnect, device number 3

Why is it disconnecting?? In rescue mode it reconnects automatically. I can even launch lightdm from rescue mode and then use it with keyboard and mouse.

dmesg rescue mode

Other "real" USB devices have the same problem. The vPro device must be a virtual USB.

  • Did you try using Solaar to pair your devices? It might not be the case, but it's worth a shot. – Tico May 6 '16 at 11:53
  • 1
    @GAD3R - again, please stop adding the actual text you are editing into the edit summary; the edit summary should be something like "formatting, removing thanks, fixed missing stuff" etc – don_crissti May 6 '16 at 12:26
  • @Tico: thanks! but I don't have problems with the logitech receiver. It isn't a unifying receiver at all. Standard old 2,4Ghz. Replugging it and it is working fine. Even after a restart! – daftmab May 6 '16 at 19:17
  • @daftmab Plugging it back to front USB and same Problem again. dmesg connect -> disconnect. Problem persists on USB Hub 2-x! (Perhaps?) Logitech Receiver 2-1.3 / vPro KVM 2-3. But not in secure mode or live CD!! – daftmab May 8 '16 at 0:38
0

My /etc/rc.local was wired. I deleted it. And now everything seems fine.

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
su user -c '/home/user/scripte/synergyc.sh' &
exit 0

This is my current script. But the broken one looked exactly the same. How do I mark the question as solved?

  • You'll have to wait a couple of days before you can mark your own answer as the correct one. – Joe May 9 '16 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.