1

I have a NAS share for my Linux server which I mount using the following command.

mount -t nfs  172.16.2.115:/shares/OwnCloud /eStore/

now to automate this I added the following line in /etc/fstab

172.16.2.115:/shares/OwnCloud   /eStore         nfs     rw,addr=172.16.2.115,auto       0 0

but it is not working and I am not getting any error also.

If I execute mount -a then mount is able to mount the NAS based on /etc/fstab configuration.

I would like it to mount at boot.

1
  • 1
    guys I don'y understand what you achieved by editing my question....seriously it was not required. May 8, 2016 at 19:00

1 Answer 1

0

edit your /etc/fstab with this below line, you don't need to mention the address again.

192.168.178.4:/shares/OwnCloud /eStore nfs auto,_netdev,noatime,nolock,bg,intr,tcp,actimeo=1800 0 0

You can mention the credentials username=User,password=Pass also

1
  • It's really the _netdev option that's the special sauce, here. That tells the kernel to wait to mount this filesystem until after the network has been enabled.
    – Thomas N
    May 6, 2016 at 16:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .