0

I'm installing Network Simulator 3.25 on a CentOS 6.5 machine.

In my environment I cannot use any repository, every single packet have to be downloaded from a machine and then transferred to the others.

I have two version of python : 2.6 and 2.7. NS-3 ./configuration uses the 2.6 one.

I'm building NS-3 with waf and so far I had no issue other than with PyViz visualizer.

In particular I can't get rid of

(Missing python modules: gtk, goocanvas)

Initially even pygraphviz module was missing but installing the right packages solved it. So I expected the same result from gtk and goocanvas but it's not the case. (If i use python 2.7 also pygraphviz module` is missing)

I tried both with source files and rpms but NS-3 ./configuration still can't find them. Both modules are in /usr/lib/pkgconfig/.

Any idea ?

0

The solution was simple ... there was a mismatch between some libraries. In particular, reinstalling gtk2-2.20.1-4 packet (libgtk-x11-2.0.so.0 was causing some trouble) did the trick.

The issue was found testing pygtk-demo :

undefined symbol: gdk_pixbuf_format_get_type

Now NS-3 is detecting all packages correctly and I was able to install PyViz visualizer module

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.