1

I am trying to install Fedora 23 on VirtualBox running on Windows 10 host. I am using Fedora-Live-Workstation-x86_64-23-10.iso to install.

Configuration Selected:

  • RAM allocated: 4096 MB
  • HDD allocated: 64 GB, Fixed
  • Processors allocated: 2, PAE/NX selected
  • Display memory allocated: 128 MB (full)
  • 3D Acceleration: Enabled
  • OS Selected: Fedora 23 64-bit
  • VirtualBox version: 4.3

Host machine Configuration

  • Intel i3-4150@3.5GHz, 8GB RAM, 500GB HDD, Onboard Intel graphics

Problem: During installation it shows the screen where you have to select between Install to hard drive and start fedora. Right at that screen I get Oh no! Something has gone wrong message. Even if I exhibit lightning reflexes and select any of the options, this error is the end result.

I can press Ctrl+Alt+F2 to launch a terminal. But again I am clueless here.

P.S.: Sometimes, only some time, a smaller frame overlaps this message. This frame is like a peep hole to installation process. Lot of scrolling in all directions helps install Fedora, but this error appears on reboot.

What other information can I provide?

EDIT 1:

The same configuration works flawlessly on a colleague's computer. Only he has alloted 12 MB as video memory without acceleration of any kind. I made those same changes with no effect.

EDIT 2: My colleague is running his virtualbox on Windows 8.1 (Mine is Windows 10). I believe this may be a cause of the said error.

  • Try using the Basic Graphics installation option and see if the issue is still there. – schaiba May 4 '16 at 11:21
  • You can also hit Ctrl+L in the "Oracle VM VirtualBox Manager" to see the log files. Maybe there is something useful logged. – mnille May 4 '16 at 11:22
  • @schaiba I do not see such an option. – abyshukla May 4 '16 at 11:48
  • Also turn off PAE option – fpmurphy May 4 '16 at 11:56
  • 1
    My bet is that you need to enable virtualization technology on your BIOS as already said by @GAD3R – user34720 May 4 '16 at 16:42
0

Well, some digging revealed that my version of Windows 10 was not compatible with virtualbox and fedora's GDM.

Steps taken:

  1. Press Ctrl+Alt+F2
  2. Enter your username
  3. Enter the password

The below commands are to be run on the terminal

  1. Remove GDM (gnome desktop manager) entirely. Command sudo dnf remove gdm*
  2. Install XFCE or some such (anything except the friggin' Gnome. sudo dnf install xfce

Not marking as a solution, since it's only a workaround. Or maybe, to rack up some points, I might mark it as one later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.