Last night, I shutdown my system, and when I tried to boot it this morning it hung at the splash screen. What is wrong here? I'm not sure which details I can give apart from that I originally installed the OS from bootable USB and Gnome is the desktop environment I am using.

During boot, when I enter the GRUB v1.99 screen, the following (editable) text appears:

setparams 'Fedora Linux, with Linux 3.1.0-7.fc16.i686 (recovery mode)'
set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod ext2
set root='(hd0, gpt2)'
search --no-floppy --fs-uuid --set=root 9ff50bad-320d-4f07-8a14-4cd372185815
echo 'Loading Linux 3.1.0-7.fc16.i686 ...'
linux /vmlinuz-3.1.0-7.fc16.i686 root=/dev/mpper/vg_user-lv_root ro single \'
rd.lvm.lv=vg_user/lv_root rd.md=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 \`
rhgb rd.luks=0 LANG=en_US.UTF-8 rd.lvm.lv=vg_user/lv_swap
echo 'Loading initial ramdisk ...'
initrd /initramfs-3.1.0-7.fc16.i686.img
  • might be issues with hardware
    – Mughil
    Commented Dec 31, 2011 at 18:56
  • Does the bootable USB have a rescue mode or a live mode? You might be able to use that to get access to any system logs. Commented Dec 31, 2011 at 19:02

1 Answer 1


To be able to see what is going on during the boot with Fedora you can try pressing "Escape", the splash screen should be replaced by the boot text, and look for errors there. If you do not even get to the boot progress/splash screen, then you will want to edit the kernel's command line and remove "rhgb" and "quiet" from it. To do this, hold shift during the bootloader (grub) stage then follow the instructions (press 'e' to edit, etc..) - or maybe your bootloader is already visible during startup (showing a timer before booting the default option) in which case just press a key (ie: arrows) before the time is up.

This should allow you to see what the problem is, but chances are that you will need to boot from a usb stick to fix them. Most bootable distros have a rescue mode.

Did you apply a kernel update recently? If so, you may want to try the previous kernel - normally just below in the bootloader list.

If you are confident with linux system tools, you can also boot with init=/bin/bash on the kernel command line then take it from there.

  • Thank you for your answer. I removed quiet and rhgb from the bootloader and then, after a minute of output to the screen, was given a DOS-like screen. Figuring it to be the terminal, I typed shutdown -r now. When the machine rebooted, I was directed to my normal splash screen and prompted to login, as if nothing had gone wrong. Can you provide explanation as to why your suggested changes fixed the problem?
    – Jubbles
    Commented Dec 31, 2011 at 20:03
  • 1
    I have no idea what happened there! The grub info you posted is pretty standard, note though that your system is not up to date: the current fedora 3.1 kernel is 3.1.6-1. You may want to check the system log for information /var/log/messages
    – totaam
    Commented Dec 31, 2011 at 20:04
  • In the Terminal, I ran the command su -c "tail /var/log/messages*", entered my password, and received the messages. I have some messages for today; is there anything in particular that I'm looking for?
    – Jubbles
    Commented Dec 31, 2011 at 20:09
  • open it up with a proper text editor and look for the time when you rebooted by hand, there may be something near there (just before - or even after, who knows?) and also the previous boot which did not succeed.
    – totaam
    Commented Dec 31, 2011 at 20:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .