3

After travelling with my ThinkPad x121e on suspend my resolution has altered and the correct resolution setting disappeared. This affects the whole computer, when using live USB as well. I do not expect a reinstall to work (I will reinstall later tonight perhaps to make sure). I run Linux Mint 11 x32, with the Intel Sandy Bridge graphics. Before travelling the resolution was fine, it recognised the correct 1366x768 resolution. After travelling, a whole new set of resolution options have appeared and it currently recognises 1280x800 as the optimal resolution. 4cm is missing from the right, 2cm from the bottom.

I have already tried adding a new resolution mode using xrandr. This does not seem to work. I tried to add a new resolution mode setting, but it would not recognise the mode even when I had added it. It seemed to add it as DP1 instead.

The Linux Mint forums suggested editing the grub configuration to insert vga=844, but this also did not work. What else can I try?

1
  • Frustrating, this has just happened to me too. I run Debian and have just downgraded my test root FS to the current sid (It was a several-months out of date mix of sid/experimental). The problem occurred after that and happens for the BIOS and other root FS too. I wonder if its a bad driver, microcode, firmware or similar
    – jmtd
    Jan 31, 2014 at 21:24

1 Answer 1

0

I solved this by power cycling the laptop. Most, if not all laptops are power cycled when you remove the cord and battery then holding the power button for about a minute (to be sure).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .