0

In the context of an application that transfers some files to an ovh storage, and I am experiencing some problems mounting a fuse file system.

This is the structure of my mount point in fstab

mystorage   /mnt/openstack  svfs    username=my-user-name,password=my-password,tenant=my-tenant,region=BHS1,container=my-container-name,noauto,users,user,suid,rw 1

According to my understanding, this line would allow executing

mount /mnt/openstack

to any user. In effect, I successfully mount the fuse file system. Unfortunately, and this is my specific problem, after mounting I cannot neither copy nor read what is inside the /mnt/openstack directory because I do not have permissions. However, I am sure the file system is mounted because through sudo I can manipulate the directory without any problem. For instance, the commands:

sudo ls -l /mnt/openstack

which oputputs:

total 0
-rwx------ 1 root root 432249 May  2 09:02 26-14818.jpg
-rwx------ 1 root root    447 Apr 29 11:14 401error.html
-rwx------ 1 root root    438 Apr 29 11:14 404error.html
-rwx------ 1 root root    468 Apr 29 11:14 503error.html
drwx------ 1 root root   4096 Aug 30  1754 images
-rwx------ 1 root root    313 Apr 29 11:14 index.html
-rwx------ 1 root root   1876 Apr 29 11:14 listing.css
drwx------ 1 root root   4096 Aug 30  1754 styles

and

sudo cp a-file /mnt/openstack

work perfectly.

EDITED:

The output of sudo ls -ld /mnt/openstack

drwx------ 1 root root 665505 May  3 08:53 /mnt/openstack

A remark: the permissions of /mnt/openstack before mounting are 777`

So my questions are: what am I doing wrong? What could I do in order to manage mounting and manipulate the mounted directory as the user?

  • Can you show us the output of sudo ls -ld /mnt/openstack and sudo ls -l /mnt/openstack (edit your question to include the output) – EightBitTony May 3 '16 at 12:34
  • @EightBitTony I edited the question and put the output that you request. Thanks – lrleon May 3 '16 at 13:07
3

I think mount does not support this use of user with the default fuse security setting (or allow_root). I think the resulting permissions are the same as if you used sudo mount. To allow access by multiple non-root users, you could set allow_other, allowing access by any user.

If this raised concerns, it would be possible to set default_permissions to enable permissions checking, set a group with the gid= mount option, add selected users to that group, and set mode=770 to allow full read-write access by the group.

Or if you only need access by your user, you could simply use allow_other,default_permissions,uid=user. Note that in this case there's no particular need to use fstab. You could save your mount command as a script instead, call it something like mount-openstack and put it ~/.local/bin.

  • 1
    I solved thus: noauto,user,allow_other,default_permissions,uid=user. Apparently, it works! Thanks! – lrleon May 3 '16 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.