0

While trying to run apt-get update on linux mint 17.3 I am getting following error.

W: GPG error: http://extra.linuxmint.com rosa Release: The following 
signatures were invalid: BADSIG 3EE67F3D0FF405B2 Clement Lefebvre (Linux 
Mint Package Repository v1) <root@linuxmint.com>

I tried adding key 3EE67F3D0FF405B2 as mentioned on this post but the key remains unchanged and there no expired key in the list either.

The content of my official source package list file is as follows

deb http://free.nchc.org.tw/linuxmint/packages rosa main upstream import 

deb http://extra.linuxmint.com rosa main

deb http://np.archive.ubuntu.com/ubuntu trusty main restricted universe multiverse
deb http://np.archive.ubuntu.com/ubuntu trusty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ trusty partner

The mirror site http://free.nchc.org.tw/linuxmint/packages and extra repo site http://extra.linuxmint.com have identical structure. What is causing the error and how to resolve it?

Also is there alternative mirror for http://extra.linuxmint.com rosa main??

1

Try to install the keyring:

sudo apt-get install --allow-unauthenticated linuxmint-keyring

Then:

sudo rm -rf /var/lib/apt/lists/*
apt update
sudo apt-get update
sudo apt-get upgrade
| improve this answer | |
  • I get linuxmint-keyring is already the newest version.0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded. – Santosh Linkha May 3 '16 at 10:58
  • Is there alternative mirror for deb http://extra.linuxmint.com rosa main?? – Santosh Linkha May 3 '16 at 11:05
0

I had the same problem with version 17 Qiana. I slightly adapted the above:

Installed the Keyring (might not be required?):

sudo apt-get install --allow-unauthenticated linuxmint-keyring

Removed files associated with extra.linuxmint.com from /var/lib/apt/lists:

sudo rm /var/lib/apt/lists/extra.linuxmint.com_dists_qiana*

Then ran the updates (but not the upgrade):

sudo apt update
sudo apt-get update

Then I reran update manager and it worked without errors.

Note: on checking I found that this process had restored a new set of four extra.linuxmint.com_dist_qiana_.... files all dated 11 Feb 2016 in /var/lib/apt/lists, whereas previously there were only three such files some of which had later date stamps. No doubt someone somewhere knows how this came about ...

| improve this answer | |
  • apt update and apt-get update do the same thing, apt-get is just depreciated. – AveryFreeman Jun 8 '19 at 2:48
0

Came across this and it's old but for others who find it: Just want to add that none of this the fixes described above are necessary (with current versions of Ubuntu/Mint at least). All you have to do is change mirrors on the "Software Sources" GUI. I had the EU one selected, randomly was getting this same error msg detailed in OP After trying so many methods, I discovered all I had to do was change to USA one - fixed. If that doesn't work keep trying different mirrors until it does. This isn't an uncommon situation.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.