4

I am using Manjaro KDE edition. I have a system with Skylake i5 processor and hybrid graphics.

System:    Host: aditya-laptop Kernel: 4.4.8-1-MANJARO x86_64 (64 bit gcc: 5.3.0)
           Desktop: KDE Plasma 5.6.3 (Qt 5.6.0) Distro: Manjaro Linux
Machine:   System: HP product: HP Notebook v: Type1ProductConfigId
           Mobo: HP model: 8136 v: 31.36 Bios: Insyde v: F.1F date: 01/18/2016
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9603
           clock speeds: max: 2800 MHz 1: 699 MHz 2: 2694 MHz 3: 750 MHz 4: 750 MHz
Graphics:  Card-1: Intel Skylake Integrated Graphics bus-ID: 00:02.0
           Card-2: Advanced Micro Devices [AMD/ATI] Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330]
           bus-ID: 01:00.0
           Display Server: X.Org 1.17.4 drivers: ati,radeon,intel     Resolution: 1920x1080@60.06hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 11.2.1 Direct Rendering: Yes 

With an earlier version of kernel 4.4 as well as drivers, PRIME offloading worked properly with the commands xrandr --setprovideroffloadsink radeon Intel

However now after updating the kernel and xf86 drivers, it does not work.

$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x66 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 3 associated providers: 0 name:Intel
Provider 1: id: 0x3f cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:HAINAN @ pci:0000:01:00.0
$ xrandr --setprovideroffloadsink  0x3f 0x66
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  34 (RRSetProviderOffloadSink)
  Value in failed request:  0x3f
  Serial number of failed request:  16
  Current serial number in output stream:  17

I don't know where exactly the problem is as many packages got updated, which includes the kernel as well as xf86-video-intel and xf86-video-ati packages. I have also installed the linux4.6 kernel but I get the same problem on that too.

2

It was a bug that got fixed with the next release of the kernels.

If someone has to use the affected kernel, they can use the radeon.nopm=0 kernel boot time option which is a workaround.

The related bug report here on freedesktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.