2

Apple authorized support changed the top case and keyboard on my Macbook Air that was manufactured in 2011 and the new keyboard layout is not recognized.

I've installed Arch on this notebook but I can't figure out how to make the keyboard layout work properly because the keyboard is Brazilian and includes characters such as the 'Ç' key.

Here's a photo of the keyboard: keyboard picture

Typing the character on the left produces the character on the right:

~ prints '
^ prints "
ç prints ;
Ç prints :
, prints , (ok)
. prints . (ok)
> prints ~
< prints `
& prints ^
( prints *
) prints (
\ prints \ (ok)
| prints | (ok)

I also need to use accents like ç, é, ã, õ, etc... So I can type in Brazilian Portuguese when I need to.

Any help would be greatly appreciated.

  • 3
    Your layout is set to US. Why don't you open the keyboard configuration interface of whatever desktop environment you're using and switch the keyboard layout to Brazilian? If you need help with that, what environment are you using? – Gilles 'SO- stop being evil' May 2 '16 at 22:51
  • @Gilles Thank you! I just don't realized it was possible. I'm using KDE Plasma 5, so: System Settings > Input Devices > Keyboard. In the hardware tab I selected the Keyboard Model "Apple | Apple". In the Layouts tab I just added a new layout: [Map: pt, Layout: Portuguese, Variant: Portuguese (Macintosh)]. And it worked great. – fschuindt May 5 '16 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.