I have recently backed up my remote virtual machine and downloaded the data into my local. I did the setup on my local with VMware workstation and tried starting the server. I realized I missed copying the 2nd drive so while it is still downloading the 2nd drive I tried to remove the reference on the VMware config for now and started the VM again.

This time it got through but I can't login with my password. So I tried to start it with single for single user mode (bypass password). But it is still asking me, here is a screenshot:

enter image description here

If I try to continue (ctrl+D) instead I get this looping prompt for password:

enter image description here

What could be wrong, and how can I log in now? Is the problem because I removed the 2nd drive? Should I just add it back in (when the download is completed). Would everything go back to normal after and allow me to use the single user mode to reset my password?


Start another Linux VM, and mount that disk to repair the problem.

In addition, to avoid the password entered in single user mode, change as follows /lib/systemd/system/rescue.service.

--- /lib/systemd/system/rescue.service.orig     2015-11-20 13:49:03.000000000 +0900
+++ /lib/systemd/system/rescue.service  2016-04-11 15:58:31.002000000 +0900
@@ -18,11 +18,11 @@
 ExecStartPre=-/bin/plymouth quit
 ExecStartPre=-/bin/echo -e 'Welcome to emergency mode! After logging in, type "journalctl -xb" to view\\nsystem logs, "systemctl reboot" to reboot, "systemctl default" or ^D to\\nboot into default mode.'
-ExecStart=-/bin/sh -c "/usr/sbin/sulogin; /usr/bin/systemctl --fail --no-block default"
  • Be looking into this tonight. Thanks. Upvoted for the script provided. – majidarif May 4 '16 at 3:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.