1

I recently installed Debian on my ARM Android tablet. However, I'm having trouble finding a good web browser. I've added the Raspbian repos in addition to the standard Debian repos, but I can't find a web browser to use. The packages of browsers I can install are of very old versions. It seems that nobody compiles ARM versions of popular browsers anymore. I've tried a Ubuntu community version, but it terminates in a seg fault. I've also began to try to build from source, but it always has some missing dependency, and that dependency has its own dependencies, and I end up installing hundreds of packages just to build Midrori, Konqueror, Epiphany, or Chromium. I've also tried Arora, but it also terminates in an error. In desperation I tried this. Any ideas? I'm running Debian Jessie.

  • 1
    Iceweasel is crap, Firefox for ARM is very old, NetSurf doesn't support new web standards, Midrori, Konqueror, and Epiphany for ARM don't seem to be supported anymore, Chromium exits with seg fault, Arora exits with some error, and ChromeOS for Linux, well, click on the link in my question. – GeoffreyS May 2 '16 at 15:57
  • 4
    Instead of commenting, edit your post. – Alexander Batischev May 2 '16 at 19:06
  • 1
    Iceweasel is not crap, it's Firefox actually. – McSinyx May 4 '16 at 3:33
  • Well, it doesn't always work right. For instance, it shows me the mobile page of Google. – GeoffreyS May 4 '16 at 16:38
1

You should try Midori browser

sudo apt-get install midori

It works for me.

  • 1
    I am using Debian Jessie, and it complains there is no installation candidate. – CaTx Dec 30 '17 at 1:06
1

Okay, I have found a solution. I added the ports.ubuntu.com repo and set it to trusty. It has armhf ports of most i386 packages available to Ubuntu. It also includes fairly up-to-date versions of Firefox, Chromium, and other packages. Just don't remove the existing Debian repos and use pinning to set this as a lower priority. Works like a charm!

The repo line to insert into sources.list is: deb http://ports.ubuntu.com [release] main multiverse restricted universe

Repeat for -backports, -proposed, -updates, and -security.

  • Hi, it would be great if you could give exact instructions in the solution. – Marius Hofert Nov 20 '16 at 2:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.