I am trying to install Fedora into a Lenovo Thinkpad Yoga 260 Ultrabook. So apparently I need to add a line "intel_pstate=no_hwp" to the grub boot parameters.

These are the only issues I've found related to this pc. The issue seems to be due to Skylake hardware and the threads I've found regarding this bug on StackExchange were all in regards to Xubuntu. If I edit the full name of my iso down to the name of the formatted usb I can get Fedora to start, but it freezes on the title screen.

So I've watched several videos on youtube and read these questions. I attempted to edit the boot parameters of the live usb but it was to no avail but that is no recommended at any rate. It seems that in order to really do this, it has to be booted and loaded so that you can edit manually with terminal.

As for me, I am able to boot to what looks like what people have indicated to edit by pressing e. Which reads :

setparams 'Start Fedora Live'

linuxefi /isolinux/vmlinuz0 root=live:Label=Fedora-Live-WS-x86_64-23-10 ro rd.live.image quiet rhgb

intrdefi /isolinux/intrd0.img

If I do not perform any edit it fails to boot and then I am taken to a # command screen.

If I ctrl-c I am taken to a grub command menu.

Is that the splash screen? Anyway, I assume that I have to ctrl-c and edit with grub rather than just edit the screen as is or simply edit this screen to include "intel_pstate=no_hwp".

How do I add "intel_pstate=no_hwp" to the GRUB boot parameters? Can someone please provide grub commands to help me? And if that is not the case, in how should I phrase the options above to include "intel_pstate=no_hwp"? No where on this setparams page does it say "splash" so I am getting no where.

Should I attempt to make a master iso?

This is a link to the bugzilla page. The only other issues involving this bug were in regards to Xbuntu so I didn't include them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.