0

I have a Lenovo Thinkpad t460 that I can't get to see wireless networks. Here is the output of sudo lshw -C network:

  *-network UNCLAIMED     
       description: Network controller
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 3a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:f1000000-f1001fff
  *-network
       description: Ethernet interface
       product: Ethernet Connection I219-LM
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: eth0
       version: 21
       serial: 50:7b:9d:bf:9a:f8
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotia

Here is the output of lspci -nnk | grep -iA2 net; uname -a:

00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection I219-LM [8086:156f] (rev 21)
    Subsystem: Lenovo Device [17aa:2233]
    Kernel driver in use: e1000e
--
04:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)
    Subsystem: Intel Corporation Device [8086:0130]
Linux ComputerName 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

I have tried the solution in this post, but still does not work. Anybody have any ideas for me? Thanks!

1
  • Please edit the question to include results for lspci -nnk | grep -iA2 net; uname -a as the answer you linked to may not be the correct answer
    – Jeremy31
    May 2, 2016 at 23:38

2 Answers 2

0

Ok, I feel dumb now. Jeremy31's comment got me thinking about my subsystem, and that led me back to this thread. I had already decided that this didn't help me as I didn't have this subsystem, but then it suddenly hit me that I could apply the same solution by changing the line to my subsystem number. Bingo! It worked. Thanks for helping me think this through.

0
0

According to the wireless.wiki you need to download iwlwifi-8000-ucode-25.30.13.0.tgz firmware.

Extract it and copy the file to /lib/firmware

wget https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-8000-ucode-25.30.13.0.tgz
tar xzvf iwlwifi-8000-ucode-25.30.13.0.tgz
cd iwlwifi-8000-ucode-25.30.13.0
cp iwlwifi-*.ucode /lib/firmware

Edit

Load the driver:

modprobe -r iwlwifi
modprobe iwlwifi
1
  • I started doing that solution, but I already had that file in lib/firmware May 3, 2016 at 3:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .