10

I have increased the font size by going to System Settings -> Font. This changed it for some applications like Konsole and File explorer.

But this doesn't reflect in other applications like Firefox and Intellij.

2 Answers 2

8

The "System Settings" and "Font" dialog will (as a rule) affect only desktop applications which have been integrated with it. In your configuration, those are KDE applications.

In X, most applications manage their fontsizes by themselves, and are not affected by these dialogs. Or, even if there is some nominal integration, it may not be maintained. For instance, the thread firefox ignores system font settings on ubuntu summarizes the cause by

The problem is that (non-repository) Firefox builds in Ubuntu or any Linux distro, by default, uses it's own Cairo rather than system Cairo for rendering UI fonts. I forgot which bug report (Bugzilla, Launchpad) I found this in since it was some time ago but the fix is fairly easy.

along with a fix for that application:

In about.config set layout.css.dpi to 0.

1
  • I had the same problem in Kubuntu 20.04. All application fonts looked ok except for Firefox and Thunderbird (either from ubuntu repository, or downloaded binaries), where fonts were tiny. I tried layout.css.dpi but no luck. What worked for me was enabling Force font DPI and setting it to 140 in System Settings -> Fonts. The value of 140 I found by trial and error such that KDE application fonts look the same as if the option were left unchecked. Then I could confirm that xdpyinfo | grep resolution reports 139x140 dots per inch. Firefox assumed 96 instead.
    – iavr
    Oct 25, 2020 at 14:45
0

The right approach (as suggested by KDE 5.24.6 when you try to enable Force font DPI) is to change the Global scale option in Display and Monitor -> Display Configuration. For me, 125% worked like a charm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .