-2

So I have the following problem.

I want to install BlackArch on an USB.

I downloaded the Live ISO (64Bit) and used PowerISO to make a bootable USB. I am on Windows 8.1 so I hit Windows + C, went to Settings, holded Shift and hit restart.

Then I booted from the USB. After that this error showed up:

Failed to start loader.efi: Not found"

Also the file vmlinuz.efi was not found.

After that I used the Fedora Media USB Creator. After booting from the USB the loader was found but then the next error showed up:

:: Mounting '/dev/disk/by-label/BLACKARCH_201601' to 'run/archiso/bootmnt'
Waiting 30 seconds for device /dev/disk/by-label/ARCH_201212 ...
ERROR: '/dev/disk/by-label/BLACKARCH_201601' device did not show up after 30 seconds...
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can't access tty; job control turned off

So I found out that I have to rename the USB to BLACKARCH_201601 but there is a problem. The max length for renaming is 11 characters. So I googled and found out that I can change the label with an autorun.inf file. But that didn't work. Secure and Fastboot are disabled. Its an ASUS Laptop with Windows 8.1 and UEFI.

Any ideas?

EDIT:

Okay so now I checked out the Files on the USB Stick and there was a .conf file which had a line Called label=BLACKARCH_201601. I changed it to ARCH_EFI and renamed the USB ARCH_EFI. That worked! Now he could mount /dev/disk/by-label/ARCH_EFI. But now there is a new error:

Failed to mount /dev/loop0
  • Use another software to make the USB key. Read: ArchLinux Wiki – cylgalad May 2 '16 at 8:23
  • @cylgalad Ok I tried "Rufus" now which is mentioned on the Wiki. Same problem tho. Rufus created a simple Autorun.inf aswell – Shad0w May 2 '16 at 17:06
  • Have you tried the good old dd method (on a Linux machine)? Btw, there's a more recent version (2016-04-28) on Blackarch maybe they fixed that problem. – cylgalad May 3 '16 at 6:55
0

If, like me, you want to run BlackArch from a USB(Live/Persistent) you need to do a Linux to Linux install. As another person has said here, you can not use Win32DiskImager, Universal USB Installer, or any other USB 'Flasher'. You have to use dd in a Linux installation.

I spent two weeks trying to do it myself, but you just can't get there. Too much work. Too many errors. Syslinux and then cfg problems ensue.

0

You must use dd command, I've tried with Win32Imager and gotten far but mkfs has issues, install guide even says to use dd.

Easiest is to fresh install Arch, download BlackArch and execute:

sudo dd bs=512M if=blackarch-linux.iso of=/dev/sda;

  • Overwriting /dev/sda would be a sure way to break most installations as they boot from that drive. – Anthon May 20 '16 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.