0

My HDMI sound is connected from an intel NUC core i3 (a version without all the extra legacy serial and vga interfaces) and connected to a 1080p ViewSonic Monitor with built in speakers. My sound mysteriously failed again, after having worked just fine for a couple of months. (this is a repeating issue) This has happened several times before. Sometimes a shutdown and restart restores the sound after a few tries, other times it takes many days, then a shutdown/restart immediately restores the sound. In all the other cases of HDMI sound failure to my Viewsonic Monitor, the sound (if it inexplicably resolves) will occur immediately after a restart, and without prior settings readjustment. And, in every case the sound was originally working just fine, up until the Intel NUC was powered off for whatever reason reason.

I've checked all the normal things like mute buttons, sound settings, but adjusting those never helps. The settings are correct because they were working beforehand.

This has happened with numerous Linux operating systems. Right now I'm using Kubuntu 14.04. ...then eventually, sometimes days later but immediately after a restart, the sound starts working again, inexplicably. Any ideas what's going on? (I'm the only one who uses this computer)

I don't believe it's a hardware issue because when the sound does work, it works perfectly, and when the sound fails, it fails completely, and both the sound-failure and the sound-fix are somehow triggered by Restarting the system, so I believe it's not a mechanical issue with the sound.

I just tested the HDMI cable and my monitor (Viewsonic 1080p with built in speakers) using a Raspberry Pi 2 running Ubuntu Mate. The sound works fine. Next I will test both the Pi2 and my Intel NUC on a Big TV, to see what works, and what doesn't...

...testing complete. I've found the solution that worked this time, and am posting it for posterity, and to others facing the problem of their HDMI sound mysteriously going out after powering their Intel NUC off.

  • Given it has happened "with numerous Linux operating systems", did you ensure it's not a hardware issue? If so, can you update the post to reflect that? – Alexander Batischev May 1 '16 at 18:22
  • Okay, I added an extra paragraph explaining why I don't think there is a mechanical problem in the hardware – user12711 May 1 '16 at 18:53
  • 2
    The thing is, you didn't ensure it's not hardware-related. There's too many variables at play, but the fact that the problem persisted points either at faulty hardware or at the problem in the sound subsystem that is common on all distros and haven't been fixed yet. The latter is far less likely than the former, so you'd better start checking the hardware. Try different cable. Check if moving the jack inside the socket changes anything. Try a different machine but the same monitor. Try this same machine with a different monitor. – Alexander Batischev May 1 '16 at 18:59
  • will do. I'll report back, probably tomorrow. – user12711 May 1 '16 at 19:09
  • I just did half of my hardware tests. There is nothing wrong with the monitor or HDMI cable. I added this paragraph: --- I just tested the HDMI cable and my monitor (Viewsonic 1080p with built in speakers) using a Raspberry Pi 2 running Ubuntu Mate. The sound works fine. Next I will test both the Pi2 and my Intel NUC on a Big TV, to see what works, and what doesn't. (next report tomorrow) – user12711 May 1 '16 at 19:31
1

The Intel NUC has two HDMI output ports. This causes a problem with the settings sometimes. Especially if there is a power outtage or sudden power off. That's because there are two identically titled HDMI setting profiles as shown below. And the settings sometimes revert from one profile to the other on my Intel NUC. If you "hotswap" the hdmi cables to the other hdmi port, Kubuntu will autodetect the change and automatically change the profile, as necessary. Even if I have the correct profile selected, I can hotswap to the other hdmi port on my Intel NUC and Kubuntu swaps the hardware profiles as necessary (I tried this by cutting off the monitor, but not the Intel NUC, then swapping the cable to the other port). That should fix the problem. The problem seems to occur with sudden poweroffs, then the hardware profiles can get shuffled around to the other unselcted hardware profile. Restarting may or may not fix it. So, either a "hotswap" or a manual hardware profile change becomes necessary... (shown below)

To manually change the port using the port that the cable is currently plugged into, follow the following instructions.

TO ADJUST HDMI SETTINGS on Kubuntu (and I suppose other KDE Linux Distributions) select from the [K]menu:

Applications>Settings>System Settings>Audio and Video Settings>

DIALOG BOX: (audio and video settings)

[Device Preference][Audio Hardware Setup][Backend]

(notice those dialog tabs)

[Device Preference] tab

(notice that only one option is selectable, the other grayed out and unselectable)

  • Built-in Audio Digital Stereo (HDMI) [ selected ]
  • Built-in Audio Digital Stereo (HDMI)
  • Dummy Output
  • Built-in Audio Digital Surround 5.1 (HDMI)

(If sound is not working, then the cable must be connected to the other option, which isn't selectable, so go to the Audio Hardware Setup tab as shown...

Select this...

[Audio Hardware] tab

[Profile] dropdown menu

  • Digital Stereo (HDMI) Output [ selected ]
  • Digital Stereo (HDMI) Output
  • Digital Surround 5.1 Output
  • Off

(So select the other Digital Stereo (HDMI) Output option. Then notice back on the tab that the other Built-in Audio Digital Stereo (HDMI) option is selected, while all the other options are grayed out and unselectable.

I will have to type this up and tack it to my bullentin board, else I'll surely forget it this the next time it happens. I believe the "restarts" can sometimes cause Kubuntu to autodetect the HDMI port the Intel NUC is connected to, but then again sometimes it doesnt seem to. (I had previously done a dozen restarts, including complete power offs and unplugging everything, to no avail).

SO: Whatever Linux Distribution you have working with the Intel NUC, look for two identically titled HDMI profiles and try the other profile by the same name, because the unit has two HDMI ports, and the cable is connected to the other port with an identical profile title.

...and your hardware profile settings may then look something like this...

[Device Preference] tab

(notice that only one option is selectable, the other grayed out and unselectable)

  • Built-in Audio Digital Stereo (HDMI)
  • Built-in Audio Digital Stereo (HDMI) [ selected ]
  • Dummy Output
  • Built-in Audio Digital Surround 5.1 (HDMI)

(If sound is not working, then the cable must be connected to the other option, which isn't selectable, so go to the Audio Hardware Setup tab as shown...

Select this...

[Audio Hardware] tab

[Profile] dropdown menu

  • Digital Stereo (HDMI) Output
  • Digital Stereo (HDMI) Output [ selected ]
  • Digital Surround 5.1 Output
  • Off

...and therefore it's worth remembering that the two configurations do NOT do the same thing for your audio.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.