2

I have successfully installed Windows 10 on a 3-disk (hardware) RAID 0 setup, in a 150GB NTFS partition. As part of that, and because I booted my installation media in UEFI mode, the Windows installer created an EFI partition. The disks in the raid group all have a GPT partition table. I'm attempting to install Fedora 23 (in UEFI mode) in order to dual boot.

In following various guides, it looks like all I need to do is mount the existing EFI System Partition (created by Windows) at /boot/efi, create my other partitions as desired, and everything should work.

Unfortunately, it doesn't look like the F23 installer is recognizing the EFI partition created by Windows as a valid option. When hitting DONE to apply my partition changes, I get an "Error checking storage configuration". Clicking the link for more details reads as such:

No valid boot loader target device found. See below for details.
For a UEFI installation, you must include an EFI System Partition
on a GPT-formatted disk, mounted at /boot/efi.

However, the disk meets those requirements. The relevant output of sudo parted -l reads:

$ sudo parted -l
Partition Table: gpt

Number  Start    End    Size    File system    Name                 Flags
2       473MB    578MB  105MB   fat32          EFI system partition boot, esp

I have disabled Windows' "fast boot" via the Power Management control panel.

Any help or pointers in the right direction would be greatly appreciated; I'm tired of programming on my old, slow laptop and would love to utilize my desktop's resources.

Update #1
After reading through this bug report this morning, I think I may have found my issue. When installing Windows 10, it creates a 450MB "recovery partition" containing WinRE, the Windows Recovery Environment -- this is the first partition on the RAID0 volume, the ESP is second. I've got to go into the office now, but will update this post if I find a resolution tonight.

Specifically, I believe comment #59 on that issue may be the solution I'm looking for.

1

A solution

So it looks like I have found a working solution given my particular environment.

I'll first describe my goals and environment, and then give step-by-step instructions.

Goals

  • Side-by-side installation Fedora 23 and Windows 10 in UEFI mode.

Environment

  • One hardware-based RAID0 volume, formatted using a GPT partition table. (Let's call this group r0)
  • Two separate 1TB internal hard disk drives, (sdd and sde)
  • Two bootable USBs containing the latest release of F23 as of this post, and Windows 10 (created using the windows media creation tool)
  • A motherboard capable of booting said installation media in UEFI mode.

Steps

  1. Insert installation media for F23. Boot in UEFI mode and select "install to hard drive".

  2. When selecting the disks, I chose "r0" and "sdd", and then chose "I will configure partitioning.

  3. Change the new partition type from the default (LVM) to "Standard Partition".

  4. Create your partitions. After creating each partition, check the settings and ensure that the partition is only on your desired drive. Note that the sizes below are what I chose to use -- your partition sizes may differ based on needs and availability. I created the following partitions, in order:

    • /boot/efi, 500MB, on r0, as an EFI System Partition
    • /, 50GB, on r0, ext4
    • /var, 20GB, on r0, ext4
    • /home, size left blank, on sdd, ext4 (after creation I reduced the partition size by 4GB)
    • swap, 4GB, on sdd
  5. Click "Done". At this point, you will receive a warning saying that no valid boot loader was found. Press "Done" again to bypass it.

  6. Click "Select disks" again. Select the same disk(s). At the bottom of the window, click "Full summary". In the window that pops up, select the boot drive (the drive with the ESP partition mounted at /boot/efi). Click "remove boot flag", and then click "add boot flag".

  7. Click done. You'll be at the partitioning screen again. Click done and accept the changes. Voila! You can now install Fedora. Continue with the installation - it should be pretty straightforward from here on.

  8. To install Windows 10, I simply inserted my installation media (after installing and updating Fedora) and when through the install process. When given the option, choose "Custom Install". Choose the boot drive (r0 in my case), and add a new partition to it - I went with 150GB. Windows popped up with its normal "we might create additional partitions" alert -- hit okay. At this point, I also chose to format "sde" so that I could see my internal HDD when I booted into Windows. Complete the installation process. Wonderfully, you'll notice that Windows has not overridden your efi partition but simply added to it -- unfortunately, we aren't done yet.

  9. Restart and enter your F23 desktop. At this point, you'll have noticed that we didn't have Windows as an option in the GRUB menu. To fix that, we need to create a new menu entry in /etc/grub.d/40_custom:

    menuentry "Microsoft Windows 10 UEFI-GPT" { insmod part_gpt insmod fat insmod search_fs_uuid insmod chain search --fs-uuid --set=root --hint-efi=hd0,gpt1 DEVICE_ID chainloader /EFI/Microsoft/Boot/bootmgfw.efi }

  10. After saving the file, you'll need to regenerate you grub config. Run grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg and voila! You are done!

  • "Click "remove boot flag", and then click "add boot flag"" - unfortunately this doesn't help for Fedora 26. Seems Fedora developers have "fixed" that. :( – Yaroslav Nikitenko Oct 22 '17 at 15:50
0

Installed Fedora 26 on MacBook Pro. Faced this problem. After hours of pain read carefully the bug report and in the middle of that found

So the required "Linux HFS+ ESP" is what this error message is referring to. You need to create a standard partition, ~100-200MB in size, and set the type to Linux HFS+ ESP. That's where GRUB will go, and the installer will stop complaining.

This solved the problem (just used this partition type instead of ESP). However I must add that on my another (HP) laptop the ESP is called EFI System Partition and that caused no problems with an installation of Fedora Core 24 when I was doing that.

The maintainers should make the error message in Anaconda very clean and precise to save people's time, and avoid new/(incompatible with previous versions) behaviour.

Other solutions/(possible reasons) may be found at the bug page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy