1

I'm attempting to host a website from home using a Raspberry Pi with this tutorial. After following all of the instructions and finally testing the result by entering the NoIP address in my browser, I am sent to my Asus RT-AC66U router configuration page and not to the Pi. I tried following different port forwarding guides such as this one, yet I'm still being sent to the wrong page. My Raspberry Pi's local IP is 192.168.1.48 and it is using port 24. Here is a screenshot of the settings I am using in the config page.

Screenshot of my port forwarding settings

What am I doing wrong?

4
  • When connecting to your NoIP address, are you specifying the port? You should. Apr 28, 2016 at 22:33
  • I'm not sure I understand... You mean when I edit the IPv4 address in NoIP I should include port 24? Apr 28, 2016 at 23:42
  • Ok, so I tried navigating the NoIP with an added "/24" at the end of the address, and I get "Settings have been updated. Web page will now refresh. Changes have been made to the IP address or port number. You will now be disconnected from RT-AC66U. To access the settings of RT-AC66U, reconnect to the wireless network and use the updated IP address and port number." Apr 28, 2016 at 23:46
  • No, I mean that you should specify the port in your browser when connecting to NoIP address. Suppose that NoIP gives you address "example.com" (I have no idea how they really look, sorry.) Then in your browser, you should type "example.com:2424" (screenshot shows that you're redirecting on port 2424, not 24.) If you omit ":2424" from the address, browser will use 80 instead; but on your router, port 80 is already used by router's web interface. Apr 29, 2016 at 8:01

1 Answer 1

1

I think you are redirecting port 2424 of your router to port 2424 of 192.168.1.48.

If I'm not wrong you should change the value 2424 in the field 'Local port' to just 24.

6
  • Thanks for the response. However, after trying it, the error persists. I also tried what Alexander Batischev (see comment above) suggested and it did not work either... Any ideas? Apr 29, 2016 at 16:23
  • Do you test the Rasp by itself? I mean, trying to connect to the website with a PC within the same network by typing in the browser 192.168.1.48:24.
    – migrc
    Apr 30, 2016 at 18:23
  • Yes, I did and it works. I get the "It works" page. Apr 30, 2016 at 18:24
  • Ok. After doing the port forwarding from port 2424 to 192.168.1.48 port 24 (like I said in my answer) try to conect to the rasp typing in the browser <public IP address>:2424. Using your router's public IP address (don't show it here). It can be obtained using the website 'whatsmyip' for example.
    – migrc
    Apr 30, 2016 at 18:34
  • Thanks for the suggestion. I tried two things : <public IP address>:2424, which returned "This site can't be reached", and I tried <public IP address>/2424, which returned "Settings have been updated. Web page will now refresh. Changes have been made to the IP address or port number. You will now be disconnected from RT-AC66U. To access the settings of RT-AC66U, reconnect to the wireless network and use the updated IP address and port number." Does this message help with anything? May 1, 2016 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.