2

Since a few weeks Cinnamon on my Debian "Jessie" 8 system suddenly started to start with the X keyboard layout set to US English.

It does that even though in the "Keyboard" settings the German layout I would like to be the preferred layout is the topmost listed.

It does this even when the US English keyboard layout is removed from the list completely.

I already tried to reset the keyboard settings to default, but that didn't have any effect. I do not remember to have changed anything that could have caused this.

As a workaround I added setxkbmap de as a "Startup Application". This solves the problem for the time being, but also hides the keyboard switcher applet from my menu bar. So this sets it to German but doesn't allow me to easily switch the layouts anymore.

I'm looking for a way to make it honor the topmost layout as default again. But if have any leads on what could be causing these problems, this would be also greatly appreciated.

EDIT

Here's what is in my /etc/default/keyboard file (after I used setxkbmap de in that session):

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="de"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
3
  • What do you have in your /etc/default/keyboard ?
    – gapz
    Apr 28, 2016 at 21:10
  • @gapz Added it to my question.
    – aef
    Apr 28, 2016 at 21:13
  • Actually, changing the settings in the "Keyboard" tool doesn't have any visible effect on the contents of /etc/default/keyboard
    – aef
    Apr 28, 2016 at 21:17

1 Answer 1

2

I had the same problem, and your workaround works well. You can hold the switcher applet (and the switcher keyboard-shortcut) by executing setxkbmap -layout de,us as a startup application. This will work if the topmost listed layout in keyboard settings is US keyboard. If not, then command must be setxkbmap -layout us,de.

I think is a strange bug in cinnamon or gnome keyboard settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.