1

I have to install Mysql as a metastore for the cloudera HUE.

But on that machine, it seems MariaDB is on that machine. I use yum to install

yum install mysql-community-server

I got this error.

Error: Package: MySQL-python-1.2.3-11.el7.x86_64 (@centos)
      Requires: libmysqlclient.so.18(libmysqlclient_18)(64bit)
      Removing: 1:mariadb-libs-5.5.44-2.el7.centos.x86_64 (@centos)
          libmysqlclient.so.18(libmysqlclient_18)(64bit)
      Obsoleted By: mysql-community-libs-5.7.12-1.el6.x86_64 (mysql57-commu                                          nity)
          Not found
Error: Package: MySQL-python-1.2.3-11.el7.x86_64 (@centos)
      Requires: libmysqlclient.so.18()(64bit)
      Removing: 1:mariadb-libs-5.5.44-2.el7.centos.x86_64 (@centos)
          libmysqlclient.so.18()(64bit)
      Obsoleted By: mysql-community-libs-5.7.12-1.el6.x86_64 (mysql57-commu                                          nity)
         ~libmysqlclient.so.20()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

But I can't remove mariadb-libs, because the Cloudera need it.

Somebody please give some suggestions.

Thanks.

  • 1
    Are you sure you need MySQL specifically? MariaDB is meant to be a compatible replacement. (That's why the mariadb-libs package provides a libmysqlclient.so.18 file.) – Wyzard Apr 28 '16 at 6:28
  • i will try. I am not sure. Can I connect to mariadb using MySQL client? If so, then I can use mariadb instead of MySQL database. – cdhit Apr 28 '16 at 18:09
  • 1
    I believe that should work; MariaDB uses the same protocol as MySQL so the a MySQL client can talk to a MariaDB server. – Wyzard May 2 '16 at 1:28
  • I used tarball installation, unix.stackexchange.com/a/350820/117555 – chepe lucho Mar 11 '17 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.