3

I'm using Arch Linux with i3 window manager, and Chrome and Firefox seem to be the only things that won't take the GTK font that I've selected. When I try to change the font in either browser, it still looks the same.

Because it's happening in both browsers, I'm assuming I have some global font configured that is overriding my changes. How do I fix this?

enter image description here

2

The menu fonts should change based on your GTK font, but the font used in web pages is a combination of firefox settings and fontconfig.

To change the setting in Firefox for example, go to Edit > Preferences > 'Content' tab > and click the 'Advanced' button next to 'Default font'. Here you can change the setting for various languages.

If you want to see which font actually gets used for a particular setting in Firefox you can check with the command line: fc-match -s FONT_NAME

This shows the fallback order too, so if characters are missing from the first one in the list then the next font in the list will be used, and so on. If you want to change this order you can look up how to modify the fontconfig for your Linux distribution, where there are options for system-wide configuration as well as per-user configurations via a file like ~/.config/fontconfig/fonts.conf

If you want to verify your settings in Firefox you can visit a page, right click some text and select "Inspect Element", click the "Inspector" tab, and then click the "Fonts" tab in the smaller window on the right. This will show all fonts being used by firefox for a particular element.

  • I had my GTK font set to "Sans". Using fc-match -s FONT_NAME | grep Sans, I was able to identify that the font "Sans" wasn't actually working in Chrome or Firefox. I'm not totally sure why that's the case, but changing it to a font from that list did the trick. Thanks so much! – austincrft Apr 27 '16 at 16:11
  • Firefox by default requests "sans". So if you do "fc-match -s sans" then that'll tell you what it was using. Also using "grep sans" isn't helpful because fc-match -s returns an ordered list with the one at the very top being the one that's actually used, so if your font name wasn't at the top when you do "fc-match -s sans" then that probably explains why you weren't getting the result you expected in Firefox. – cue67 Apr 27 '16 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.