2

I'm having difficulty gettings fonts to display correctly in xterm. The situation is complicated by this being a headless server which I'm connecting to from a Macbook Pro via xpra, with no desktop environment installed on the server.

It does appear that ~/.Xresources is being read. But if the contents are simply

XTerm*renderFont: true
XTerm*faceName: mono:normal:size=9

then the font used is italicized and seemingly bold.

What are the minimal contents I need in the Xresources file to get a non-italicized, monospace font?

Some related questions:

  • I always (or almost always) get this warning: Cannot convert string "nil2" to type FontStruct
  • In any given xterm, how do I list the font it's actually using? I've found solutions on the web for listing the default font that will be used (e.g. appres), but not for the one actually being used in this particular instance.
  • You might try fc-match mono:normal:size=9 – meuh Apr 27 '16 at 14:09
3

The xterm manual shows an option which may help (added in patch #298 in 2013):

-report-fonts
Print a report to the standard output showing information about fonts which are loaded. This corresponds to the reportFonts resource.

Also, appres is useful for showing what resources are used, e.g.,

*VT100.font3:   6x10
*VT100.font4:   7x13
*VT100.font5:   9x15
*VT100.font6:   10x20
*VT100.font1:   nil2
*VT100.font2:   5x7

When xterm cannot allocate a font, it tries to use fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.