0

I am running Debian Jessie with xfce.

I used to have the system in English (en_US.utf8 as LANG since I installed debian only with English).

Lately, I installed new locales and even if I made sure I chose None for the default locale, as advised on the wiki, I noticed that one of the installed locale, German is now set (LANG=de_DE.utf8 when I run locale).

I followed the instructions on the other wiki about changing the locale, ie.

# export=en_US.utf8

and then

dpkg-reconfigure locales

and then restarting.

But I still get LANG=de_DE.utf8 and de_DE.utf8 for all the LC_* variables (LANGUAGE is set to English though).

I even removed the German local, rerun the export and dpkg-reconfigure locales and restarted but I still have LANG=de_DE.utf8.

What am I missing here?

Could it come from xfce session and startup settings? I looked a bit there but I'm not sure if I might not break other stuff by playing around with those settings.

migrated from stackoverflow.com Apr 26 '16 at 17:42

This question came from our site for professional and enthusiast programmers.

0

you are using a wrong order:

export=en_US.utf-8

this should be:

export LC_ALL=en_US.utf-8

or:

export LANG=en_US.utf-8

Anyway, as the Debian wiki says, the use of LC_ALL is discouraged as it only lasts while session (i.e: an open terminal session). You could add it to a startup script, but this is discouraged again by Debian's wiki.

If you just want to change your locale definitely, you must add your desired locale to /etc/locale.gen. After that, run:

locale-gen

and after that, verify the recently generated locale with:

locale -a

en_US.utf-8 should appear as an output of that order.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.