A while back I installed i3 on my MATE box, and I'm quite happy with it, however despite disabling Caja Desktop (x-caja-desktop) when setting i3 as the default window manager through dconf editor, every time I install a .deb package via the gui installer, the desktop "window" opens and overlays my entire screen.

This is incredibly annoying, and hitting super-shift-q to close the window doesn't work, which forces me to just move it to an unused workspace.

Is there anything I can do to stop this from happening without installing a different file manager?

  • Did you find a solution to this problem? – user44400 Jul 30 '16 at 11:24
  • @user44400 nope, I have not – Electric Coffee Jul 31 '16 at 20:24
  • Despite that, do you still use mate with i3? – user44400 Aug 1 '16 at 8:22
  • Yeah I like the menu bar – Electric Coffee Aug 1 '16 at 9:14

Try to set: dconf key org.mate.background.show-desktop-icons to: false

  • I don't have a background entry under org.mate – Electric Coffee May 18 '16 at 9:16
  • I do not have it either. – user44400 Jul 28 '16 at 9:14
  • For Ubuntu Mate 18.04, it should be org.mate.desktop.background.show-desktop-icons (notice "desktop" after "mate"). See my answer. – Mat.R May 27 '18 at 15:23

For Ubuntu Mate 18.04:

Open a terminal and run the following command:

dconf write /org/mate/desktop/background/show-desktop-icons false

Tip: if you want to force to close the window which overlay your desktop or any windows, you can open a terminal and run the following command:


Then, click anywhere on the window you want to close and it should close.


You can start Caja with the --no-desktop option to prevent it from opening the desktop.


In the console, type:

dconf key org.mate.background.show-desktop-icons false

This change is persistent, i.e. it will not be undone on reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.