5

I'm not exactly sure how to formulate this, however:

When I scroll using mousewheel or two-finger touchpad gesture, the page in Chrome or Firefox continues scrolling for a bit after I've put my fingers aside from touchpad or mouse.

I don't want this feature in my system, and I'm not sure how is it called. This feature sometimes leads to unwanted behaviour, e.g. if I use ctrl-hotkey in a short sequence after scrolling, page zooms, even though I don't scroll at the time.

2 questions - how this thing is called, and how do I disable it entirely without disabling wheel/touchpad scrolling?

  • I found a person with same problem: askubuntu.com/questions/640444/stop-scrolling-on-fingers-up but this thread only encourages to "disable scrolling", which is not something I would want to do. – Mikhail Krutov Apr 25 '16 at 12:39
  • I've found the solution for the problem (answered on ubuntu questions); not sure if I should duplicate the answer here. If possible, this question should be removed or set as duplicate of linked question. – Mikhail Krutov Apr 25 '16 at 12:46
  • Please post the answer here. There's no mechanism for closing a question as a duplicate of a question on another site because different communities tend to give different answers (for example, we tend to use the command line and configuration files, whereas Ask Ubuntu favors GUIs). – Gilles Apr 25 '16 at 22:36
  • @Gilles, ok I've duplicated myanswer from linked asubuntu thread. – Mikhail Krutov Apr 26 '16 at 6:27
5

Feature is called "Coasting speed". To disable it you can use:

xinput --set-prop --type=float "<your device>" "Synaptics Coasting Speed" 0 0

to list devices you can use:

xinput list

alternative variant (for touchpads) is synclient options (there are 3 of them):

CornerCoasting          = 0
CoastingSpeed           = 0
CoastingFriction        = 0
2

Alternative variant #2, as xinput changes are temporary within a session:

In order to make changes permanent, do this:

  1. Run xinput and find your mouse/touchpad name there.

  2. Put a file with this content into /etc/X11/xorg.conf.d/ directory:

    Section "InputClass"
      Identifier "Disable Synaptics Coasting"
      MatchDriver "synaptics"
      MatchProduct "<(part of) your device's name>"
      Option "CoastingSpeed" "0"
    EndSection
    

For a full and detailed list of options for synaptics driver, check this page:

https://www.mankier.com/4/synaptics

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.